0

This issue has been solved. I was having an issue with my local CDN after a major internet outage that spanned over two weeks.

I am trying to create a new Rust server for my friend and I to play on, but have run into an issue while trying to create it.

I install SteamCMD, no problems there. However, when I create a .bat file to start downloading the Rust dedicated server, it repeats the same message for around two minutes,

Update state (0x3) reconfiguring, progress 0.00 (0 / 0)

thereafter failing with the error message:

Error! App '255850' state is is 0x2 after update job.

The CMD session then outputs that the work queue is not empty and quits the prompt.

I have allowed my download queue on Steam to finish and I have disabled my firewall to no avail.

Any suggestions?

1

thanks for your reply, but this error has since been fixed. It turns out there was a problem with my local CDN, after a major internet outage that affected my area.

My apologies for not clarifying that I no longer require assistance on this issue. And again, thank you for the reply.

  • No problem -- glad you got it working :) That was a strange error, lol. – l3l_aze Mar 15 '18 at 20:35
0

The values need to be converted from hexadecimal to decimal (0x at the beginning denotes hex), but 0x0-0x9 are just 0-9 so they're simple. The Steam appmanifest status values can be found in this document from the Lutris app on GitHub. In your case the app is not downloading properly so it ends up with a state of "2" or "UpdateRequired" as it still wants to update.

Have you tried just using SteamCMD directly without a script? It would help confirm it's an issue with Steam/installing the server instead of with your BAT script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.