6

I have Super Mario Galaxy 2 in the Dolphin Emulator. Since I have to point for certain things and use the joystick on the nunchuck for general movement (and I don't have a USB sensor bar), I want to play with the nunchuck in my left hand and the computer mouse in my right hand, while the Wiimote just lies around (because I don't have a third hand).

I've set mouse up/down/left/right to move my cursor in the game up/down/left/right (I don't remember the name of the setting right now) and that works fine, except that it only does so sometimes. The in-game cursor appears and disappears seemingly randomly, sometimes for a second, sometimes for 10 minutes, sometimes until I restart the emulation or change the configuration of the controller and change it back.

Setup: American version of Super Mario Galaxy 2 (SB401?)
Dolphin 5.0 (ac267a29405ae768037a8774b84b805a4180d1af)
Windows 7 Professional 64bit +SP1 enter image description here

How can I make the cursor reliable?

  • I believe your mouse is leaving the game screen area if that makes sense. You need to program Dolphin to respond to the movement of the mouse, not the location of the mouse cursor. – FoxMcCloud Nov 27 '17 at 20:03
  • You mean IR up/down/left/right is not correct? What else should I choose? And no, it's not an issue of the mouse cursor leaving the game, because sometimes it stops working while the cursor is clearly in the middle of the screen and also I can move around the mouse wildly and it doesn't fix it. – Fabian Röling Nov 27 '17 at 20:13
  • What about the Height Center and Width values below that. You have them all at 50 - I saw a reddit thread while researching this that said to try and turn that values up. Not 100% sure what they do, but I think they will give you more "pick up" room – FoxMcCloud Nov 27 '17 at 20:56
  • Can you search for a link? – Fabian Röling Nov 27 '17 at 21:00
3

From an answer from one of the developers of Dolphin (archive): This is a bug in the current version of Dolphin. It only affects hybrid Wiimote mode, emulated Wiimote mode works.

0

If you don't mind can you post your settings? It would make finding the problem a lot easier.

As for quick fixes, make sure you have hybrid Wiimote enabled, and disable every option apart from IR in the configuration. Do note that the motion controls are actually a lot better in the earlier versions of Dolphin, in V3.0 it is much less buggy. V5.0 is fairly buggy in general when using the mouse as motion controls, but the method described above gives the best results. I have V5.0 for Gamecube games and Wii games that don't involve motion controls (like Smash Brothers), and V3.0 for more motion control intensive games like Super Mario Galaxy. Hope this helps.

  • The setting is just plainly called "Cursor Y-", "Cursor Y+", "Cursor X-" and "Cursor X+" in the category "IR". I'll attach a picture with the configuration now. – Fabian Röling Nov 14 '17 at 17:56
  • Maybe I didn't make it clear enough before: This answer didn't solve the problem for me. – Fabian Röling Nov 21 '17 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.