4

I've played Dwarf fortress in the past, and mining has worked.

However, upon starting a new game, I've found that mining designations are not working.

I am designating solid ground (not above the ground, and corner to corner as per usual designation). But the designation will not show an indicator that it is queued and the job list is empty. I've gotten it to work in previous builds (roughly a year ago).

plant gathering and tree chopping works, so does stockpile designation and channeling.

I've attached an image showing the area that I am designating (and yes, I am mining with d -> d -> designated area).

  • 2
    Could you take a full screenshot of when you try to designate a mining area? – Wrigglenite Dec 1 '17 at 8:12
  • You found a solution? Just started playing the game today and encountered the same problem v.v Especially frustrating if u think its you doing it wrong... – Zaibis Oct 22 at 17:42
6

check the bottom right of the interface when you have "Mine" selected. Most likely you have the designation as "Designate/automine ore/gems".

0

Do you have any dwarfs with the mining labor? Check your units. If you don't see any Miners in that list, you can assign one by viewing a unit, setting their preferences for labor, and enabling Mining up at the top.

  • 1
    That wouldn't prevent mining from being designated at all. – Wrigglenite Dec 1 '17 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.