2

I've noticed this behavior when playing either Just Cause 3 or The Crew. My FPS is usually from 40+ to 60. But from time to time, it drops to ~20 FPS. Then usually after a minute, it goes back to my normal FPS. These are my Specs:

  • Windows 10 Fall Creators update (Build 16299.125), 64-bit
  • Lenovo Y50-70 notebook, 15-inch FHD IPS screen
  • Intel i7-4720HQ
  • NVIDIA GTX 960M, Driver 388.71 (release date: 12/20/2017)
  • 16.0GB Dual-Channel DDR3 RAM @ 799MHz
  • 931GB Western Digital WDC WD10S21X-24R1BT0-SSHD-8GB (SATA)

Things I've already done:

  • Windowed mode
  • Disabled "Override high DPI scaling behavior"
  • Enabled "Disable fullscreen optimizations"
  • Disabled everything relating to the Game Bar/DVR.

Edit:

  • Windows Defender's Periodic Scanning is off.
  • Kaspersky Free Antivirus's idle scan and rootkit scan are disabled.

Notes:

  • I have only Kaspersky Free Antivirus as my security program.
  • This gets triggered mostly during intense action sequence or speedy animations.
  • But sometimes this happens abruptly.
  • What's consistent is it always goes back to the my usual FPS, albeit the duration of the drop varies.
  • This doesn't happen before. Although I can't remember when this started happening. The first time I completed Just Cause 3, this never happened.

What else can I try? On top of my head is try using DDU and then reinstall the latest graphics driver. Using DDU and reinstalling the latest drivers didn't resolve the issue. Thank you very much.

  • how often does this happen? do you have any antivirus or other systems that would run periodic scanning? – Rapitor Dec 26 '17 at 20:11
  • The first time I upgraded to Windows 10, I also often faced this issue. I suspected Windows Defender was automatically scanning the loaded files. Try to whitelist the game folder if you want. – antimo Dec 27 '17 at 9:08
  • I've updated my quetion. Thanks, guys. The periodic scanning that I know of are already disabled. I'll try whitelisting the game folder from them. – d4ryl3 Dec 31 '17 at 9:43
2

Have you cleaned your computer recently, especially the vents and fans? Seeing as you have been using this laptop for around 2 years, this could be your GPU throttling to prevent overheating.

I had an Alienware M17x gaming laptop that after a few years of use would throttle the GPU due to bad airflow to prevent the risk of damage. After cracking it open I saw the fans were covered in dust.

If the laptop is getting hot and airflow is not ideal, the GPU will reduce the framerate dramatically to protect the GPU and allow the GPU to cool down. For me that was generally 10-30 seconds.

This could explain why this is a new issue to games that didn't exhibit this behavior in the past. Your laptop could have had better airflow the first time around (this was certainly the case with me).

This happening during intense action sequences also could be an indicator that as your GPU works harder to perform in those sequences, it becomes hotter and your computer decides to throttle it.

A good way to test for this is to download a GPU stress testing software - since I'm no expert, here's a popular result from a sister site.

I fixed my issue by first cleaning my vents and fans in the laptop, and then taking it to a store to have the thermal paste re-applied to my GPU. Also consider the position in which you use the laptop. If you keep it in your lap or on a soft surface, the problem could be exacerbated by further blocking the airflow.

  • Oh, I haven't considered that. I've never cleaned this notebook. Actually never opened it even. I'll check out GPU-Z based on the link you provided and see if that's the case. In any case, I'll just clean the fans. Thank you. – d4ryl3 Jan 2 '18 at 20:51
1

This could be caused by a number of events.

  • A background process could have started
  • An area could have not finished loading before you moved into it
  • Something could have been taken out of memory

->Also, your game could be auto saving of quick saving, I have the same graphics chip in my laptop and whenever it quick saves the FPS drops to 20 for a couple of seconds, but I have much faster RAM.

But from looking at your specs it might be a RAM issue. 799MHz is very slow and could affect loading times and save times

  • But these events happen almost without notice, though, many times due to intense graphics animation. This doesn't happen before and I've been using this for 2 years now. Do you think my RAM is going bad instead (which I hope not)? Thank you. – d4ryl3 Dec 31 '17 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.