4

As brought up in related questions here on Arqade, the in-game console can easily disable achievements if you accidentally hit the tilde button ~, furthermore for people who lack the self-control not to cheat, disabling the console seems like a good option.

However I can't seem to figure out how to actually disable it. Plenty of tutorials suggest setting bAllowConsole to 0 in various .ini files, but that doesn't seem to do anything.

Perhaps there is a way to rebind the key from tilde to something else (like a key that doesn't exist on most keyboards?)

  • Gently pull out the key from keyboard. Or use AutoHotkey to remap it. – Sinatr Jan 10 '18 at 16:28
  • @Sinatr autohotkey does not work (tried that). Also tried using disabling the key using the registry but it looks like DirectX ignores that. – ecnepsnai Jan 10 '18 at 16:29
1

This problem is much harder to solve than it should be. As you mentioned, the bAllowConsole does not work in FNV, so your only other option is to rebind the key. Unfortunately, binding the console to a different key is something that requires changes to the engine (for lack of better phrasing), which means you’ll need to install a mod that uses the New Vegas Script Extender to do it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.