3

I've tried the usually suggested method of copying minecraft world from "saves" folder in ".minecraft" but Bukkit didn't recognize the world was even there. The world works. I've tested it a little in single player (the reason being it is 30k x 30k in map size). I'm not sure what I'm doing wrong (of course). I created the world from World Painter 2.4.1 and exported to Minecraft with unedited world (will paint it later when I know it works). I'm running and playing the server from localhost with default port. I ran and played the server with default world several times so I know the server works as it should. I'm playing Minecraft 1.12.2 (to let you all know I'm playing new version of Minecraft). I'm running server with 4 plugins, "Multiverse-Core" and the three Multiverse portal plugins.

With all this here. I've noticed the default world had "uid.dat" and mine didn't. If this is related to my issue, may someone please shed some light on it.

2

The world folder has to be called "world".

In general, if you are in such a situation, you can start with the default world, then copy the parts of the world one by one and see if they work. That way you can narrow down the cause.

1

Place the world folder from the saves directory into the root directory of the server. (the same folder the server file is in)

You have to change level-name in the server.properties file to match your world.

Bukkit will split the world into three folders which contain the overworld, the nether, and the end.

If you have done that, I would suspect multiverse has to be configured.

0

You could try downloading the WorldEdit Mod, then copying everything you want, create a schematic of it (using WE mind you), then simply putting the saved schematica into your server folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.