2

My minecraft performance degrades the longer I play. The game will start to freeze for a fraction of a second before it continues. While this starts to happen every 10 minutes, the longer I play and the more I explore, the worse it gets, until eventually it happens every second.

Looking at my task manager, there are no shortage of resources. I am running of an SSD, 32GB Ram, I have a fast graphics card (AMD Radeon R9 290X), nothing runs in the background etc. Restarting minecraft solves the problem immediately. I limited the game to 30FPS and it pretty much stays there.

It's the latest version of Oracle Java (161), 64bit.

Any idea how to solve this issue?

6
  • Are you on the latest version of Java? Have you tried clearing the java cache?
    – Gigazelle
    Jan 21, 2018 at 9:00
  • Another thing to check is to make sure you have the 64-bit version of java installed.
    – Gigazelle
    Jan 21, 2018 at 9:01
  • Thanks, updated java version, will try to clear the cache
    – uncovery
    Jan 21, 2018 at 9:11
  • 1
    Is this modded or vanilla? Yours is a perfect description of garbage collector pauses due to memory leak. Press F3 and look at the memory used on the top right to confirm.
    – Kcats
    Jan 22, 2018 at 10:20
  • I have a similar issue but related to distance traveled (especially fast) as opposed to time of gameplay - I can sit in one area for hours with no problems, but a minute of flight on Elytra and I'm into an unbearable hiccup with half-minute-long freezes.)
    – SF.
    Jan 22, 2018 at 12:11

1 Answer 1

2

This sounds exactly like excessive garbage collection. "Back in the day” we used to have to explicitly tweak the Java VM memory settings to allow at least 1GB of RAM. I thought that had been fixed.

But if nothing else works try changing the Java command line so -Xmx is a few GB.

2
  • I increased that now from 1G to 5G. Seems better already, will let you know once u have time to play some more.
    – uncovery
    Jan 22, 2018 at 11:20
  • Worked for me too. Don't go overboard. I set it to 14GB (I have 16) and the game would crash. But at 4GB the hiccup vanished completely.
    – SF.
    Jan 15, 2019 at 13:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .