6

It is the weirdest. I opened up my Steam and suddenly received this message when it had been working perfectly fine a couple of days before:

Steam popup 1

Steam popup 2

It was already installed. I tried reinstalling Steam from the package in the Steam website. I also tried purging libdrm2 and reinstalling. I tried just restarting the system. I tried updating and upgrading all components. No change.

No Google results have turned up anything that makes sense in my situation.

I'm running on Ubuntu 14.04 .

7

It turns out that Steam is 32-bit and the 64-bit libdrm2 package I have is obviously not being recognized. This was clear from the console output when running the "steam" executable directly:

$ steam
Failed to parse arguments: Option "--disable-factory" is no longer supported in this version of gnome-terminal.
Package libgl1-mesa-dri:i386 needs to be installed
Package libgl1-mesa-glx:i386 needs to be installed
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Error: You are missing the following 32-bit libraries, and Steam may not run:
libdrm.so.2
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Failed to load steamui.so - dlerror(): libdrm.so.2: wrong ELF class: ELFCLASS64
Installing breakpad exception handler for appid(steam)/version(1513371133)

The first comment indicates that it needs to be 32-bit. The second indicates that the 64-bit one isn't what it wanted.

Simply fixed by installing "libdrm2:i386":

$ sudo apt-get install libdrm2:i386
3
  • Does somebody has a solution for that (for ubuntu)? I tried a simular line on ubuntu (sudo apt-get install libXtst.so.6) but it didn't work. (If I spell words wrong, excuse me, I am hungarian)
    – Tamaz
    May 6 at 7:35
  • Hi Tamaz, welcome to Arqade. Have you taken the Tour yet? This is not a forum, so you should open a new question with your problem (which seems to be related to a different library) and try to give us as much relevant information as you can. Try launching steam from the CLI like Dustin did here and post its output. You can also use the output of ldd /path/to/steam; see the manpage why, for clues.
    – aphid
    May 6 at 9:27
  • Correct. You're not even using apt-get correctly. Your argument doesn't make sense. Use ubuntuforums.org . May 7 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.