3

I installed Fortnite, and then Windows Update tells me it needs to restart to install Windows 10 Build 17083, so I restart my PC and the update successfully installs, but the thing is - when I run Fortnite for the first time, this message pops up:

Failed to initialize BattlEye Service: Driver Load Error (193).

Failed to initialize BattlEye Service: Driver Load Error (193).

0

I fixed it by disabling virtualization in the BIOS. Not a proper fix though, I need virtualization for my Windows Server hosts in Hyper-V.

  • That's strange, I have it enabled on my machine and it runs just fine. Maybe it was just the restart? – Codingale Feb 7 '18 at 16:51
  • @Codingale maybe it's because I enabled Hyper-V? – MythicalCode_ Feb 10 '18 at 13:41
0

Here is a post on Steam from a developer who gave these ideas of solving the issue.

Hello,

Please try the following Steps, if you are experiencing issues with Battleye.

  • Make sure that BEService.exe in your BE Service directory (usually C:\Program Files (x86)\Steam\steamapps\common\Line of Sight\Binaries\Win32\BattlEye) is not blocked by your firewall in any way.

  • Ensure that there is no d3d9.dll, dxgi.dll or dsound.dll file in your game directory. If there is one please remove/rename it.

  • Ensure that you have a legitimate copy of Windows. Pirated copies might no longer be supported by the latest BE version.

  • Check if your game directory’s file permissions are broken by doing the following: Right-click on your game directory (in Windows Explorer), select “Properties” and go to the “Security” tab. In the group/user list select the “SYSTEM” entry and check if it has full access. Otherwise click “Edit…” and grant the “SYSTEM” user full access.

  • Your system’s root certificates might be broken/corrupted. To fix them download and install the following update from Microsoft: support.microsoft.com/kb/2813430.

  • Check your system files for corruptions and possibly repair them by following these guides: support.microsoft.com/kb/929833 and support.microsoft.com/kb/947821.

  • Scan your system with up-to-date anti-virus and anti-malware software. Malware that modifies system or game files can cause such issues when BE is enabled.

  • Googling the name of the blocked file can help find out what is actually behind it. Sometimes BE might block malware/adware/PUP files, which can cause problems such as being unable to find or connect to servers in-game. We recommend Malwarebytes Anti-Malware for removing such software from your system.

  • Ensure that you don’t use any tweaked/custom versions of system files (including DirectX).

  • Reinstall DirectX, see the following page for details: support.microsoft.com/kb/179113.

If these steps do not help, please also visit the Battleeye FAQ, which can be found here.

0

I had the same problem. Solved it by going to the directory where the game is installed:

FortniteGame/Binaries/Win64/BattlEye

There you will find:

Install_BattlEye.exe

Run it, and BattlEye should reinstall. That solved it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.