When I select a game like X-men Origin in my Windows 7 PC, the games opens and seems to be working, but I can't see the display. I can hear the sound of the game option when I press up & down button and also I can play some games like Assassin's Creed: Brotherhood without these issues. I don't know why!

These are the games I've tested that have these display issues:

  • Saints Row 3
  • X-men Origins
  • Call of Duty: Black Ops 1
  • Assassin's Creed 1

These games, I tested and everything works fine:

  • Sleeping Dogs
  • Batman Arkham City
  • Euro Truck Simulator
  • Assassin's Creed Brotherhood
  • If it's doing it in multiple games, it's not the game; it's your computer. You probably have the resolution set too high, and your monitor can't handle that.
    – Frank
    Feb 10, 2018 at 14:36
  • It's either the resolution or refresh rate set too high in the game by default.
    – Elise
    Feb 10, 2018 at 15:16

1 Answer 1


I have sometimes had similar issues on my Windows 10 machine. Some games - not all - will just show a black screen on launch. Sometimes I can hear sounds, other times not. It's worth noting that all the games I'm referring to are on Steam. If you're not using Steam, or if you don't have a discrete video card, this may not help.

The solution I've found is to go into my video card settings and configure it to use the discrete graphics card explicitly for that game, rather than relying on the default setting.

There has also been one game where I had to tell it to explicitly use the integrated chip instead of nVidia (go figure.)

I do this by using the following steps:

  • right-click on the desktop and choose "nVidia Control Panel"
  • go to "manage 3D settings"
  • click on "Program Settings" tab (as opposed tot eh default "Global Settings"
  • search for the game's exe file in the list
  • change the "preferred graphics processor" to "high performance nVidia"

Obviously, if you have a different video card (AMD) then the steps might be slightly different than what I do.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .