0

I have minecraft 1.7.10 running on my desktop and laptop on the same wired internet connection. As of 15 minutes ago everything was working fine, then weird stuff happened.

My laptop lost connection to the world hosted on my desktop. I tried everything in MANY other posts about common lan issues and nothing worked.

Here is what I know:

-Both are running the same version of minecraft and are physically connected to the same router via ethernet cable

-The connection worked fine for weeks, so it is unlikely there is AP isolation

-I can ping test is successful both ways after I allowed it in my laptops firewall

-Disabling the firewall on both computers does noting

-Direct connecting does nothing

-Enabling all 4 of the different java things in firewall on public and private does noting

-Both computers are on the same subnet (?) 198.168.1.XXXX

-Shutting off the laptop, computer, router and modem. Leaving them off for a full 30 seconds, then starting. Did nothing

Fixed! Read answers

18
  • Why did you not try restarting the router and changing your IP address? Feb 13, 2018 at 21:37
  • It's very weird that you can ping one way, but not the other, because a ping is in itself already a two-way operation. Can you try both again now to make sure it wasn't a temporary disconnection? Feb 13, 2018 at 21:38
  • 2
    I have been working at this for an hour and a half. I want to specifically use 1.7.10 because of the mods I use. I am using a clean 1.7.10 to troubleshoot LAN problems. Feb 13, 2018 at 21:56
  • 1
    Frank, you misread my comment. I meant that it would not fix the problem. If you read the edit, you would see I have since tried this. Also, where should I put this if it does not belong here? Not being able to connect to other LAN worlds is a problem many minecraft players have, I believe it is important for them to see a way to fix this network problem Feb 13, 2018 at 22:10
  • 3
    I'm voting to close this question as off-topic because it's tech support for modded Minecraft. Feb 14, 2018 at 7:12

1 Answer 1

0

Solution:

  • Uninstall minecraft

  • Delete the .minecraft folder in appdata/roaming

  • Restart computer

  • Use CCleaner to do basic clean and registry clean (I also backed up registry)

  • Install minecraft

Not the answer you're looking for? Browse other questions tagged .