2

This question already has an answer here:

My ps4 controller stopped working

I tried connecting it to my macbook air to play Minecraft. I held the share button and held the ps button and used bluetooth to connect to my laptop. I then tried connecting the usb cable to the usb port.

When I tried connecting it to the ps4 again, it wouldn't work, I have tried the following:

  • Sticking a pin in the little hole
  • Unplugging the wires
  • Putting it on safe mode
  • Connecting it to the ps with the charging cable

None of these worked. How do I fix the controller- I'd rather not have to buy another.

marked as duplicate by Robotnik Jul 10 '18 at 1:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Minecraft does not support gamepads. Only Windows 10 Edition (aka Pocket Edition for UWP) supports it, and it would still require a custom driver. – Manchineel Mar 9 '18 at 16:00
1

Official PS4 controller troubleshooting steps can be found here

You've covered most of the steps already, which is irritating. When you put a paperclip in the reset hole, were you holding it in for 3-5 seconds? Without that, it won't enter the pair / reset mode.

If after everything, you may need to contact Sony Support

1

Have you tried un-pairing the controller from the Macbook? I did this with my TV and couldn't get it to work until I unpaired it from the TV and then did the pin trick and then plugged it back into the PS.

  • i tried it but no luck – SAZNJR Mar 12 '18 at 2:45
1

To pair a Sixaxis DualShock® 4 Controller back to a PlayStation® 4 System after use with other systems:

  1. Turn on your PlayStation® 4 system
  2. Connect the controller to the system with the supplied USB cable. Please note that third party cables may present compatibility issues.
  3. Wait a few seconds and check if the Light Bar starts glowing yellow.
    • If the controller does not glow yellow, the cable might be faulty and/or incompatible or your controller could be damaged.
  4. Now press the PS (PlayStation®) button of your controller. It should connect to the console.
    • Try to unplug the controller. If it turns off, it needs to be charged.

And yes, I wrote this in Sony Support page style, for no inherent reason :)

0

It is fundamentally important that you press the PS button on the controller in question while the PS4 is powering up, and the blue light is blinking - do not wait until the system prompts you to press the PS button, it's too late.

  1. Turn off console.
  2. Connect controller with micro-USB cable.
  3. Turn on console manually (button on front left of PS4), and when the button lights up blue press the PS button on the controller.

In my recent experience the system took a couple of extra seconds to recognize the controller, but then it worked. I too tried all of the above troubleshooting techniques and none of them worked until I got the all-important timing correct. You'd think Sony would take care to mention this little detail.

Not the answer you're looking for? Browse other questions tagged or ask your own question.