8

When I use alt+tab on a fullscreen game to go back to the Desktop in Windows 10, most of the time the screen goes black. It doesn't happen all the time which is makes this even more confusing. It also turns black sometimes after exiting the game. I have a single monitor and an Nvidia Graphics card. Some things I've found about this:

  • I can press alt+tab again and it comes back to the game
  • I can press Windows+P two or three times and Enter to blindly try to switch to multiple monitors setup, doing two or three times gets me back to the desktop
  • I can unplug and plug again the HDMI cable and it gets me back to the desktop
  • It also happens if I try to press alt+enter to get the game to go to windowed mode

It has happened to me in the games Overwatch, Destiny2, DragonAge Origins and the Final Fantasy XV Demo, so I'm pretty sure it's a general error when going fullscreen.

Here's some research I've done for similar problems.

  • This thread in Steam forums talk about something similar in several games on Windows 7 due to the monitor set to 59hz by default. I checked and mine is set to 60hz.
  • This thread in Nvidia forums talk about this problem in GTA and they solve it by renaming the executable to something other than gta_sa.exe. This I haven't tried since I open the games from the Steam/Blizzard launchers.

Is there a way to solve this?

Update Here are the things I've tried and haven't worked:

  • Updating Nvidia Drivers
  • Switching refresh rate to 59Hz

Edit 2018-12-18 It's been a long time since I asked this question. Both Windows 10 and Nvidia Drivers had several updates since then and now I don't have this problem anymore. But I did used fullscreen windowed mode when available until I found the problem fixed itself so I'll mark that as the answer.

  • I find that this happens a lot in full screen games to me as well. I usually don't trust using Alt+Tab anymore. Instead, I just avoid having to use my computer for anything else while the game is going. I feel that renaming an .exe file won't help the issue. Perhaps playing in Window mode if the game supports it may help. – Timmy Jim Mar 9 '18 at 15:35
  • @TimmyJim yes, windowed mode avoids the issue but at the cost of some reduced performance. Also some games don't support borderless windows so they still show the menu and title bars. – solarc Mar 9 '18 at 15:40
  • Have you tried reinstalling GPU drivers? – JMac Mar 9 '18 at 16:41
  • @JMac I updated them recently but the problem persisted. I'll try uninstalling and reinstalling later and give an update. – solarc Mar 9 '18 at 19:51
2

You can fix this by running the game in full-screen windowed mode, instead of running it in full-screen. The difference here is that you might lose out a tiny bit on high graphic games. When a game runs in full screen, it occupies the whole of grapic card power, leaving none to the Host OS, While in full screen windowed mode, the game loses out a bit on the "exclusive mode" & graphical interface.

Starting a Full Screen Windowed game

  1. Download Fullscreenizer from here
  2. Extract and run fullscreenizer.
  3. Run your game in a window. If your game runs in a regular window or you can run it in a window, go to Step 4. If your game runs in fullscreen mode, try going to the game settings and then try changing the window type to windowed mode. If it is not possible to do this, then try CTRL+ALT+DEL and open task manager. This should minimize the game. In the fullscreenizer, click refresh, click on your game and click on fullscreenize. Note that this is not likely to work. Try the other solution given if this doesn't work.

  4. In the fullscreenizer, click refresh, click on your game and click on fullscreenize.

Another solution is not to fix the alt + tab, but instead to use a different solution:

Using Windows 10

Doing this on windows 10 is easier than on windows 7/8/XP, since windows 10 has this feature built in. First you must create a new desktop.

  1. Create a new desktop. You can do this using the CTRL+WIN+D or you can also click the three-window icon on the desktop and then click new desktop (see picture)

New desktop and Three-window icon

  1. Make Sure You can switch between desktops. Press Ctrl, WIN & an arrow key to switch desktops. E.G. CTRL+WIN+LEFT or CTRL+WIN+RIGHT.

  2. Running Your Application NOTE: You will probably make a new desktop on each startup. Run your game in desktop 1. Press CTRL+WIN+RIGHT to switch to desktop 2.

Using a OS that is XP or above

Since Windows XP/7/8/8.1 don't have this function built in, you will have to use the Microsoft Systernals Desktops program to achieve this. Go to this website and use the given program to create virtual desktops.

  • Hown can I make sure I can switch between desktops? When I am in game, the Ctrl + Win + Arrow Key hotkey does not work. Only outside of the game does it work. – k0pernikus Dec 18 '18 at 19:27
1

This is common among some games. I've noticed that more powerful CPU's don't get this issue as often as weaker ones since alt tabbing is pure multitasking.

If you tried:

  1. Checking the monitor refresh rate (if it is for example 59 instead of 60 hz). And check if it is the monitor at all (unplug and replug the monitor when the screen is black to check if it is working again)
  2. Reinstalling GPU drivers

If it doesn't work, you can check this thread with multiple solutions that worked for each specific user/scenario.

https://answers.microsoft.com/en-us/windows/forum/windows_10-desktop/black-screen-after-exiting-a-game-windows-10-pro/dc69b7d7-d2d0-45fb-9556-40ca83e436e3?page=4

Good luck! I had the same issue on the previous PC and the refresh rate was the problem.

  • Thanks for the link. I already checked the refresh rate and it is 60hz. Re-pluging the monitor does work but the solution I'm looking work would need to avoid doing that. I'll read the link thoroughly and report back. – solarc Mar 9 '18 at 19:56
  • If unplugging worked then it is a GPU issue with syncing the refresh to the monitor between game and windows (common on NVidia) try to set the refresh rate in nvidia 3D panel for that specific game as application controlled if the rest is ok. And play with the specs a little. Hope nvidia is working on this – Softability Mar 9 '18 at 22:25
  • I tried switching the refresh date in both the Nvidia panel and the Windows monitor settings between 59 and 60Hz, the problem still persisted. – solarc Mar 12 '18 at 17:47
1

I experienced the issue on my Windows 10 installation with an AMD Raedon RX 580.

I managed to get it working by enabling

  • Virtual Super Resolution
  • GPU Scaling

in the RAEDON SETTINGS at the Display panel. Interestingly, it continued to work even if I disable it afterwards again.

enter image description here

0

For Nvidia: Setting Scaling tab to No Scaling under Adjust Desktop Size and Position in Nvidia Control Panel fixed this behavior for me.

It was set to Aspect Ratio previously

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.