0

Streaming fullscreen with Open Broadcaster Software gives black screen. There is another stackexchange question from 2013 asking this. The answer says OBS would add this feature in the future, but it does not appear to work in 2018. Is there a secret configuration method for this to work?

Automatic scene switcher is turned on and correctly identifies the program running in FullScreen mode and switches to the scene. Scene is set up correctly, using "Game Capture" module (not "Window capture" module) set to "Capture specific window" mode, not "Capture any fullscreen application" mode. I have also tested using "Capture any fullscreen application" mode, and this also fails to capture a blatantly fullscreen game.

I want to make sure that OBS does not accidentally switch to any other full-screen program while running a fullscreen game. I do not wish to use the work-around to change the game to Borderless-Windowed mode, as it drastically decreases frame-rate.

The "Game Capture" module with "Capture specific window" mode identifies and lists the program running in fullscreen mode, so this indicates it is compatible with this mode.

  • 1
    It could be a conflict between what OBS deems a fullscreen size and what your game considers a fullscreen. I know that if your using 2+ monitors that a full screen game can actually over hang the second monitor. I would suggest trying the game in a borderless window and trying to use the game capture instead of fullscreen capture. – Mac Man Mar 12 '18 at 11:34
  • 1
    Which game are we talking about? – Hackworth Mar 12 '18 at 13:22
  • 1
    +1 to previous, it would be helpful to know the game, its settings and the hardware in use to diagnose this. – Stese Mar 12 '18 at 13:34
  • "Indication of compatibility" is not a sure thing, especially with OBS. The game you're running is important here, as OBS cannot capture Vulkan-based games at the moment (ex. Wolfenstein II; The New Colossus). – Kaizerwolf Mar 12 '18 at 15:13
  • Have we ruled out the possibility of in-game DRM (or platform DRM, like Steam) blocking the stream through third-party software like OBS? – Steve-O Mar 13 '18 at 14:30
1

OBS must be run with Administrator permissions in order to hook into the full screen rendering process.

So right click on the shortcut for OBS and click "Run as Administrator". This is tedious to do repeatedly, so, instead, right click on shortcut and click "Open File location" and do this over and over again, until you find the original .exe file in Windows Explorer (not a shortcut), then right click on the file, and click on the "Compatibility" tab, and then check-mark "Run this program as an administrator" and click "Apply" or "OK".

I discovered the answer in a Youtube comment on a video. The video itself did not have the answer. There is no competent answer anywhere else on the internet. The game is League of Legends, and running it in Windowed-Fullscreen is not an option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.