-1

Whenever I try to join a server, it says:

"Internal Exception: java.lang.Error: java.security.NoSuchAlgorithmException: AES Keygenerator not available".

I am running Minecraft version 1.12.2 on Windows 7 (although it didn't work on the previous computer, which ran Windows 10), I have moved to another country since buying the account (North America to Korea). I have actually tried this on TWO accounts, both of which was bought in America and had no problem with servers. (One of them was able to play servers in Korea, then stopped working. The other one never worked).

  • The account(s) is and always was an un-modded, legally bought Vanilla account. There were no changes made. Not even a map was downloaded.
  • I changed computers since it stopped working, but it won't work on both. I believe it sometimes works, but haven't seen it working for months.
  • I looked this up and was recommended that I download a new version of java, (latest version and the American version as well) which I did more than I can count, but to no avail.
  • I have deleted and re-installed Minecraft several times since servers stopped working, but nothing changes.
  • Tried running different Minecraft versions (1.12.2, 1.12.1, 1.12.0). Didn't change anything.

I tried running the Minecraft game output, when I was joining servers it didn't say anything but as soon as I started Minecraft it yielded these errors: (screenshot included below)

07:08:02
game
ScriptEngineManager providers.hasNext(): javax.script.ScriptEngineFactory: Error reading configuration file 
<log4j:Event logger="bib" timestamp="1516280882947" level="INFO" thread="Client thread"> 
<log4j:Message><![CDATA[Setting user: My username here]]></log4j:Message> 
</log4j:Event>

07:08:02
monitor
expected <

22:08:04
ni
Errors with built-in recipes!

22:08:04
bid
Skipping bad option: lastServer:

This has been going on for months.

I cannot find an answer ANYWHERE ELSE.

I tried asking about it on bugs.mojang.com, and their reply was:

"Your Java environment is probably not configured correctly."

Then they linked me up to the community support pages, which I already tried and had no progress with. Then they marked the problem as RESOLVED. It is NOT resolved.

My question: https://bugs.mojang.com/browse/MC-124345?attachmentOrder=desc

Their "duplicate", marked as "Won't solve": https://bugs.mojang.com/browse/MC-38608

I saw a similar post somewhere else, where the only answer was to correct the Java configuration. How do I "set the configuration correctly"??

EDIT (2018-03-21): PROBLEM IS SOLVED!! I used an alternate launcher and it worked!! https://minecraft.net/en-us/download/alternative I used the old launcher, which was the launcher I was using previously, now that I think of it. This just shows how bad Mojang is at actually responding and taking care of the users' problems.. If I followed Mojang's recommendations, I would have tried to "configure my Java correctly", when it was the launcher's problem..

  • North or south Korea? North Korea blocks a lot of things. When people say "try different versions", then they mean something like 1.12, 1.11, 1.0 (not 10) and 1.13 snapshots. To get the right Java version and settings, I would recommend uninstalling all Java versions and then just starting Minecraft again, it should download and install Java automatically. If it still doesn't work, create a launcher ticket referencing the MC ticket and explain everything. Lastly: Thank you very much for being a new user who actually tells us what you tried so far. >90% don't do that. Welcome! – Fabian Röling Mar 20 '18 at 7:09
  • What's the output of java -version in your command line? – dly Mar 20 '18 at 8:45
  • @Fabian ha ha. Obviously you're not a Korean. North Koreans don't have internet, let alone a personal computer.. The "internet" you're talking about is a makeshift version of "the internet", where 99% of everything is censored. Why (and how) in the world would they get Minecraft working?? X) – BeardWix Mar 21 '18 at 4:33
1

Please do some googling before you ask a question, but a quick search brought me to this forum post:

https://www.minecraftforum.net/forums/support/unmodified-minecraft-client/2783918-server-error-internal-exception-java-lang-error

Someone commented how to fix the problem:

You may need to reinstall the locally installed files that Minecraft puts into place.

To do so, press your Windows+R keys, type in %AppData% at the dialog, and press Enter. In the window that appears, open the .minecraft directory, and delete everything except for the saves directory that you see therein. Then, try running Minecraft again. Good luck!

You need to reinstall Java.

First, go to Programs and Features in Control Panel (Add and Remove Programs on XP). Uninstall everything that says Java in the name. Then, go to http://java.com/en/download/manual.jsp to re-install Java.

That error is caused when Java cant find the AES key generator in the security algorithms it bundles, might be caused by a version of java distributed outside the US(as they are not allowed to include them in those)

Their explanation:

That error is caused by you using a version of java that had the crypto api removed according to US laws, you will have to uninstall it and reinstall the latest from java.com

  • Look at what I SPECIFICALLY wrote up there: "I looked this up and was recommended that I download a new version of java, (latest version and the American version as well) which I did more than I can count, but to no avail." I had this problem for over a year, do you think I didn't research at all? Well, because I did. More times than I can count. It was a FRENCH minecraft forums that finally gave me the answer. forum.minecraft-france.fr/threads/… Your answer was not correct, at least for me. – BeardWix Mar 22 '18 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.