7

I'm trying to connect PS4 controller to PC but it goes under audio, so it doesn't work. I tried remove the device from audio, but it just goes back when I try to add it under something else.

What can I do?

  • Are you trying to connect it with USB cable? – arghtype Apr 6 '18 at 18:58
  • 1
    Yes, with the usb that comes with the ps4. – limecake Apr 6 '18 at 19:00
1

After plugging it in, try going to "set up USB game controllers" in control panel. (also can be searched with Cortana). If a controller is listed, click properties. See if it is recognizing your inputs. If it is recognizing your button pressing, you should be good to go. From here I used DS4 Windows to configure the controller. Set your actual audio device as default, that way the controller doesn't prevent you from hearing audio.

| improve this answer | |
1

Simply disable the controller audio device from Audio Device Settings, it worked for me.

| improve this answer | |
1

I found this on answers.microsoft.com: (thank you Kapil Arya) The below worked instantly and error free for me:

*To use your PS4 controller as a game controller, you would need to download a driver for it.

  1. Download the driver on this link: https://github.com/Jays2Kings/DS4Windows/releases/download/v1.4.52/DS4Windows.zip
  2. Extract the content of the compressed folder to a new folder that you will create.
  3. Double click on the DS4Windows.
  4. Click on Program Folder to install the drivers and your PS4 Lightbar should lit up blue. Note: Each time that you will use the controller, you would need to open the DS4Windows app first.*
| improve this answer | |
0

The way I resolved the issue is going to setting up USB game controllers via typing it into Cortana (which is also available from the control panel), selecting my PS4 controller then clicking advanced and setting it to my preferred controller. Hope this helps!

| improve this answer | |
0

The easiest way to connect the controller to a PC is using bluetooth.

To enable bluetooth on the controller, you need to first disconnect it from any device it is connected to (which can be done by simply turning off that device). Next, you must ensure that the controller has turned off completely (the light is not lit or flashing. Then, hold both the PlayStation button and the Share button until the light on the controller is flashing rapidly. At this point, the controller should be visible as a bluetooth device, and you simply need to select it on your computer. However, it is time-limited. If the light stops flashing before the PC has completely paired with the controller, it will generate an error and stop the pairing process.

NOTE: This does not work on all computers.

| improve this answer | |
0

The way I get mine to work is to go into the sound settings and 'disable' the controller for both microphone and speakers, this always resolves the issue for me, hope this helps!

| improve this answer | |
0

My fix was to disable the wireless controller in Device Manger under audio after it cuts your audio and restart. For some reason the PS4 remote even overrides your set default audio path and you can't switch back to your default, unless you restart.

| improve this answer | |
-1

Apparently you need either special software or can connect it via Bluetooth.

Details from TechRadar

| improve this answer | |
  • Ive tried ds4windows and connecting via Bluetooth. But nun of them work. On Bluetooth the controller dosent evan come up – limecake Apr 6 '18 at 20:10
  • quote from provided link: "You used to need to use specialist software to use the DualShock 4 on a PC, but Sony has now made it even easier to connect the DualShock 4 to your PC and get it running." So you don't need a special software for it now. – arghtype Apr 6 '18 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.