3

I've been having this problem for about 4-5 months now. It all started when I joined my boyfriend's hosted server using hamachi. A couple nights later, it started giving me that error. I've recently just factory reset my pc. I tried joining my brother's server (LAN) by typing in the ip or "localhost", but it still gave me the same "failed to connect to the server" message. I've tried:

  • turning the Firewall on/off
  • uninstalling and installing minecraft
  • restarting the router (even getting a new one)
  • changing port number to 25565
  • factory resetting my pc

I've tried every solution I could find, but none worked so far. I guess not a lot of people come across this problem. They said theirs were fixed in a couple of weeks, but my problem has been occurring for almost half a year now. Pls help

marked as duplicate by Virusbomb, Joachim, Tim S., Gigazelle, pinckerman Jul 10 at 23:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    localhost is your computer and not another one on your network.. did you maybe use your own PCs IP address? – dly Jun 28 '18 at 7:35
  • wouldn't localhost imply you're running your own server? did you set one up correctly – L_Church Jun 28 '18 at 8:05
  • Similar question – Timmy Jim Jun 28 '18 at 11:56
  • What version of Java are you using on your PC? – Matt Balent Jun 29 '18 at 14:14
  • @MattBalent the latest, Java version 8 update 171 – MyCwoissant Jul 1 '18 at 2:02
2
io.netty channel.AbstractChannel$AnnotatedConnectException Connection timed out: no further information

happens when you attempt to connect to a computer that you can connect to, does not have a server running.

This is because when Minecraft joins a server, it first pings for a server; remote computer on the other end, it first checks if said computer exists. This is handled by generic network code, and is on the operating system level. It succeeds because, well... A computer exists, and that the protocols running this isn't specific to Minecraft.
Then, it starts handshaking (tells the other computer "I'm a player; logging in to Minecraft now!"). Problem is that because there is no application listening to that port to handle the handshakes, the game then simply calls it a timeout, because it received no feedback as the computer on the other end, while existing, does not know what to do with the requests; so it just ignores them.

The AbstractionChannel$AnnotatedConnectException exception is a generic extendable exception class.


tl;dr

  • The computer is online, but the server software is off.
    Start it up, basically.
0

My daughter's Window 10 crashed, well sorta. I was not able to reboot Windows 10, but the Command prompt worked, which allowed me to back up some files. This told me the disk was not totally dead, but something with the boot sector was corrected somehow. So after reloading Windows 10, it was essentially a new OS (I failed to back up the PC before this occurred, my bad). Anyway, after reloading Minecraft the same problem occurred with the above error message: "Io.netty.channel.AbstractChannel$AnnotatedConnectException Connection timed out no further information". I first made sure "Discovery Mode" was turned on, which it was. Because I needed to re-install McAfee, it did not have my LAN range of 192.168.0.0/24 in it. After populating "My Network Connections" in McAfee with the range From: 192.168.0.0 to: 192.168.0.255, my PC (192.168.0.5) was able to connect to hers at 192.168.0.6. Whew, hopefully this helps someone.

Not the answer you're looking for? Browse other questions tagged or ask your own question.