I'm running ZORK.BAT on DOSBox. The problem is that whenever I want to save the game, and it asks me:

insert save disk then enter file name.
(Default is C:SAVE\ZORK1.DAT):

No matter what I wrote, it would tell me it can't find the file:

Unable to Access file

I tried to copy a file in dos (outside game) and it wouldn't work as expected. I think maybe the DOSBox doesn't have writing permissions but I couldn't figure out how to fix this.

All the files (the ZORK1 folder) are saved in c:\OLDGAMES\ in my pc. I mounted OLDGAMES to be the c drive of the DOSBox so the directory for saving the file in the box is c:\ZORK1\SAVE\ZORK1.DAT. The directory and the file exists both on my computer and in the virtual box (when commanding "dir" it shows the "SAVE" folder in the list).

  • Where'd the game come from? I suspect that's going to be critical information.
    – Frank
    Jul 4, 2018 at 22:24
  • @Frank Required information added. Jul 5, 2018 at 14:28
  • 1
    Does the C:\OLDGAMES\ZORK1\SAVE directory already exist? I wonder if it just doesn't have directory-creation privileges, but it could write to an existing directory.
    – Adam V
    Jul 5, 2018 at 17:50
  • Yes, it exists on my windows computer, and on dos as C:\zork1\save\ Even the ZORK1.DAT file exist. Jul 6, 2018 at 9:55
  • Note that the default path it displays is a drive-relative path (no backslash after C:), which may cause it to resolve to something unexpected.
    – Kevin
    Jul 6, 2018 at 21:30

1 Answer 1


Try updating the SAVE/ZORK1.DAT file attributes so it is not read-only.

This fixed it for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .