7

Any time a settler comes to any of my settlements they come equipped with armour, which is normal. But in my save, when I try to remove that armour from their inventory, they just spawn new armour to replace it. It appears to spawn the armour from a levelled list as it varies with what they spawn.
I'm not sure what could be causing this as the only mod I have installed that effects settlers is the Useful Settlers mod, but that should only start them with armour and weapons that are levelled relative to the player character.

6
  • have you turned off the mod tried to remove their armor again?
    – fja3omega
    Commented Jul 6, 2018 at 2:58
  • 1
    Yes, I've disabled and uninstalled it and there's been no change with settlers that already exist or new ones that spawn. Commented Jul 6, 2018 at 3:21
  • Have you tried giving them different clothes after removing their armor?
    – fja3omega
    Commented Jul 6, 2018 at 3:56
  • Yes. I can remove one clothing or armour item, but as soon as I remove or add another, they spawn a replacement for what I took off them. Commented Jul 6, 2018 at 4:24
  • How quick is "as soon as"? Do they immediately get new armor, or is it you leave and come back and they have armor? If raiders attack while you're gone (or there are bodies laying around) settlers have the option of grabbing armor and weapons from the corpses.
    – MivaScott
    Commented Jul 6, 2018 at 20:09

2 Answers 2

4

It's in all probability indeed a problem with that mod you use, Useful Settlers. After all, any behaviour deviating from vanilla behaviour is likely caused by mods you use, especially if one addresses settler inventory .

Moreover, in the comments section of that mod, someone seemingly complains about similar behaviour:

While this is a great mod for those wishing to never touch settler inventories, I like to customize and play around with different weapons and such. This mod puts unremoveable weapons and armor. I even disabled the mod, and now they have the items, but with a "0" after the item name. I can load up the settler, though. Oh, and don't try to remove the "0" items. You just get loaded down by phantom items that still have weight. Like I said, works like advertised, but you can't change things yourself.

So, unless you uninstall the mod (and this actually reverts all changes in-game, which it, based on that comment, won't completely do), you can only really bite that mini nuke, or see if a newer version fixe(s/d) that issue.

In vanilla Fallout 4, settlers have a basic set of clothes. Whenever you place equipment in their inventory, they will wear or wield whatever you choose (if they can). If any dynamic item of clothing is taken from their inventory, they will revert back to their default clothing.
I'm guessing the mod Useful Settlers made changes to that particular script, by having those standard clothes replaced by a list that levels with the player (like Encounter Zones, for example), with the probably unintended behaviour that it reverts to either the most recent item in that slot or another item from that levelled list.

1

I'm seriously thinking this is just a Vanilla bug: I've checked all my mods and I don't have anything that should be affecting settlers at all, and I still have this issue. No matter what I equip they always respawn their starting gear and unequip their armor.

I guess it's possible I had a mod in the past that affected something somewhere and maybe I just need to use a restorer to reset everything to vanilla.

I play on PS4 if that matters. Honestly I'm not even that bothered, though I've just been looking at it like free caps.

Edit: actually I've just realized it's not all my settlers, it's only Marcy and Jun Long having this issue. Preston and Sturges seem to have no problem keeping things equipped, neither do unnamed settlers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .