3

I have just completed the second mission of the tutorial campaign in Might and Magic: Heroes 6. However, when I click on the "Next Map" button on the screen at the end, it just starts me over on the same mission again. Additionally, when I go back to the mission selection screen from the main menu, only the first mission of the tutorial campaign appears, and none of the other campaigns are available. What is the cause of this problem, and how can I get access to the other campaigns?

2
  • 2
    You do have a full version, not the demo, right?
    – bwarner
    Commented Oct 28, 2011 at 11:50
  • I'm pretty sure this is because of uplay trying to synch your progress. You might not have any choice but to complete the 2nd map again (you can try loading a save right before you win). Commented Oct 28, 2011 at 18:11

2 Answers 2

1

You probably got disconnected from UPlay at some point and, unfortunately, may have lost some progress that did not get synched to UPlay.

1
  • I'm having the same problem, and there's no indication that I'm getting disconnected from UPlay. Commented Nov 19, 2011 at 15:19
0

Although this happened to me in a completely different game, it's worth a shot:

In StarCraft II, I had something similar happen. I finished the first mission, and I got returned to the video intro, and then the same mission again. This happened over and over till I found the workaround.

In that game, there's a bug (which Blizzard couldn't be bothered to fix), where if My Documents is mapped to a network location, the game doesn't save any progress. If you map My Documents back to a local folder, the game can save; so the workaround was to map it back locally, play the game, then map it back to the network drive after playing.

You might see if something similar can explain your case: Perhaps your My Documents or Program Files or some other essential directory isn't in the default location, and the game is poorly programmed and can't find that folder to save your progress. (I know people are saying the progress is saved online, but in SCII it saves both locally and online, and the bug still happens.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .