-2

I have a modded Minecraft map that myself and a number of others have been buildings and developing for some time now. Recently, we finally started considering moving onto a more recent build of Minecraft on SpongeForge which was a viable upgrade from the Cauldron 1.7.10 in which we could keep all the custom blocks and continue to use plugins aside them, the former being the significantly more important part, whilst enjoying all the benefits of upgrading such new features for most mods and better general stability.

So after some discussion, I got to work as owner. I checked compatibility with the mods, to which all the important ones seemed to be compatible with the recent builds and spent a few days sorting out SpongeForge with all the mods being tested alongside a variety of plugins on a local-hosted server test world.

...And then I attempted to port the actual world.

I downloaded the map from the host to put it in an give it a test on the 1.12.2 modded server but there was one problem. The log seems to say that the save predates 1.7.10 despite having run on the latest 1.7.10 Cauldron build for months.

I've been left quite confused and unsure of what to do here. I tried loading it up in 1.7.10 single player but it loads just fine and re-downloading the map again, but both yield the same message. I can't exactly try to load it up in 1.8 as a number of important mods do not support that Minecraft version meaning that a lot of things will be lost/damaged. Finally, just restarting/making a new world isn't really much of an option considering the time investment so far.

So then, for those who have stuck around the end, do you have any suggestions? Any ideas on how to fix this would be appreciated.

Server Log for Specifics - https://pastebin.com/t3LsQdYd

  • 1
    This is probably going to be dicey; we generally don't help with tech support for modded Minecraft. There might be a use case for upgrading save files, but I'm unsure if the process differs from vanilla to modded. – Frank Jul 23 '18 at 13:18
  • You mentioned a log entry that claims a wrong version, but other than that no problem. So what is your question? – Fabian Röling Jul 23 '18 at 23:54
  • I've concluded that the only way was to port via schematics and MCEdit. Sorry about that Frank, I hadn't realized that modded Minecraft questions weren't supposed to be here, I shall make sure it doesn't happen again. Normally there would be a built in method of world conversion in each version but it doesn't seem to work with this modded map it seems. As for Fabian... the problem is/was that the world, having been opened in MC 1.7.10 did not predate 1.7.10 as the error message on the server had claimed, which meant that it was giving a non-working solution of opening it in 1.7.10 or 1.8. – Castor Jul 27 '18 at 16:28
1

To be honest, this will almost certainly be impossible, if not difficult enough to be not worth it, regardless of how much progress has been made on the world. Many mods changed significantly between 1.7 and 1.12, as has forge itself. Even if all the same mods are present, some of them (Thaumcraft and Thermal [X] to name a couple big ones) have changed so significantly, that there are blocks that were removed entirely and have no new equivalent, and so nothing to convert into.

Depending on how your buildings look, the best bet might be to load it in vanilla to trim out all the modded stuff, but leave buildings in place that used only or mostly vanilla blocks, then cheat in equivalent stuff. Still, this is going to be a giant pain, and requires re-assembling all the factories and farms and stuff by hand.

  • I appreciate the answer, but this method doesn't seem to work sadly. The world still provides the same error, likely from the mods' lasting remnants on the files. As mentioned above, the only solution I've found is using schematics and porting via MCEdit. Still though, thank you ever so much for trying to help. I really appreciate it, Tal. Thanks. – Castor Jul 27 '18 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.