2

While playing Fortnite, I have two audio devices that can output audio. My laptop, and my monitor. My laptop is plugged over HDMI to the monitor.

Problem is, I dont want to use the monitor for sound, only for display. The Game sounds (such as music, Sounds effects) output through my laptop. But voice chat, output through the monitor.

In settings, whenever I try to change "Voice chat output" to Laptop, and apply, when I re go in settings, it changed to "Default".(Which is the monitor)0

Why isnt it letting me output voice chat through the same output as the game sounds? I want to use my headphones connected to the laptop.

I cant use only the laptop sinse the screen is broken

EDIT: Looking at my monitor, there is no output for heaphones only input. (For mics) (Audio IN)

2

This has happened to me quite a bit as well, the main issue I had was that it was resetting to default constantly.

The way I fixed this was opening my computer settings, and setting the audio device that I want as the "default".

After I upgrade my graphics card, it sets the monitors speakers as default as well as my actual speakers.

Going into Control Panel -> Hardware and Sound -> Sound devices, and right clicking and setting the preferred audio device as default will fix the issue.

  • My Laptop was already at default, but then I disabled the sound for my monitor. Your specific solution didint help, but you lead me in the right direction. Thanks! I cant accept your answer now(need to wait 8 mins). Thanks for the Very quick answer ! – GamerM Jul 27 '18 at 16:17
  • @GamerM Ah, on my PC when I set the stereo to default it would auto un-select the others. Glad it was fixable! – Childishforlife Jul 27 '18 at 17:37
2

The way I fixed it was going into sound and disabling the wrong output.then if it changes to default, you can just set the audio you want as default

  • I have mentioned that in a comment to the accepted answer. – GamerM Nov 5 '18 at 1:06
0

I think i found a solution. it worked for me at least.

Open up fortnite, go into settings, go to sound, look how the desired output device is called. Type/write/remember that. Exit fortnite.

Then you have to go to: C:\Users***\AppData\Local\FortniteGame\Saved\Config\WindowsClient

Right click on GameUserSettings. Click properties or whatever its called (my windows is not in English). Make sure read only is not checked on.

Double click on GameUserSettings

Look for CustomVoiceChatOutputDevice=***

Change the *** for the desired outputdevice (as it is called in the fortnite settings)

Exit the notepad-page. Click on save.

Right click on GameUserSettings. Click properties or whatever its called. Check on read only.

Open up fortnite and test if it worked.

I don't know if this last step is necessary but maybe the game itself will change this to the output it used to be. When you check on read only the game wont be able to do that. The downside of this however is you need to check of read only in order to change a setting in fortnite and have it remember the setting. I have read only always checked on because im using a streched resolution. So i am not gonna try having it checked off.

Please let me if this worked for you. im curious.

Ivo

  • A little too long of a solution, however I could try this out. I will try it out – GamerM Oct 22 '18 at 1:06
-1

Go to sound settings with your headphones plugged in disable all other speakers and microphones from your list except your headphones. Make default relaunch fortnite and Edit your settings one lore time and walla!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.