2

Okay I have a very big problem with my Half-Life 2 that appeared last year and I haven't been able to fix it since.

Since recently replaying, the eyes do not move on ANY NPC whatsoever. They simply stay in one position as if they're frozen in place. They don't look in different directions and they won't look at me. It shouldn't be bothering me this much but it just feels awkward and it's making it harder to concentrate on what they're saying.

So does anyone know why this is? I can't tell if I some how deleted a code when cleaning out my computer or my own version of steam is messing it up. I know it's only me as well cause my friend is playing it and the eyes work fine for him.

3

I believe this is fixed by the 2019-09-26 Half-Life 2 Update (emphasis mine):

Updates to Half-Life 2, Half-Life 2: Episode One, Half-Life 2: Episode Two, Half-Life 2: Lost Coast, and Half-Life: Source have been released. The changes include:

  • Fixed a hitch when saving games
  • Fixed SteamVR running when entering the settings menu
  • Fixed missing sounds on combine soldiers
  • Fixed NPCs not blinking
| improve this answer | |
  • Amazing that they still release updates for these classics. – Joachim Sep 27 '19 at 12:36
2

The first thing I would check is your graphics settings. Ensure models are not set to low, and that the settings overall match the power of your video card.

Another thing to check would be if you modified any config files (particularly autoexec.cfg). If you did, you might want to delete the config folder and validate game files so it re-downloads the ones you need. Also check the launch path to make sure there aren't any commands in there.

If none of the above fixes your issue, copying your save files to another location and doing a complete uninstall/reinstall of HL2 might be your next best option.

| improve this answer | |
1

The Orange Box update in 2010 broke the eye animations to a certain degree (the characters at least don't blink anymore): https://github.com/ValveSoftware/Source-1-Games/issues/1850

I don't know if this is exactly what you're encountering, but there's an unofficial patch to fix this specific issue.

UPDATE: The issue has now been fixed in an official patch, as pointed out by galacticninja.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.