1

I have the weirdest issue that I've been digging for a solution to for hours and am resorting to trying to post a couple places.

Controller shuts down despite having full battery in the middle of gaming. This only occurs on my main desktop PC. I've tried:

  • Hooking up different Microsoft dongles on this PC
  • Same thing happens on this PC with different controllers
  • These same controllers and dongles work fine on other PCs without ever turning off during use
  • Multiple USB ports, front and back including trying the extra USB on my keyboard/monitor which kept the distance between the controller and dongle to less than a foot apart.

So through process of elimination it HAS to be something on this specific PC that is causing the issue. Has anyone ever ran into this?

0

Same thing started happening to me. I only started getting this issue after I installed a new WiFi and Bluetooth PCIe card. Maybe turning off Bluetooth will do it?

In my particular instance the controller works fine sometimes and others it will shut down within 5 seconds of pairing. While it’s on I can move and do things but obviously it’s a pain. try fighting in dragon age inquisition when you have enough time for one attack before it turns back off.

Update: I found the solution, in another thread I saw that someone with the same issue found a work around. Once the controller disconnects once the person said he couldn’t get the controller to stay on.

Solutions 1.) (Reliable solution) If you have steam in the background (or tray) then exit it. It should work after that.

2.) (You may not have the service you need to disable) For a permanant fix turn off NVIDIA Wireless controller service from services app. Scroll down until you find the N section and find “NVIDIA Wireless Controller Services” right click and hit stop. To keep it from loading automatically right click and hit properties. On the general tab half way down it says “Startup type:” which you can set to disabled.

3.) (Purely speculation) if you have GeForce Experience you can also try disable if game stream. Open GeForce Experience. Click the gear icon near your username along the upper right. On the left side click shield and turn off game stream.

|improve this answer|||||
  • No bluetooth OR wifi on that PC unfortunately. I've seen those same other posts mention possible issues with this coming from steam or nvidia wireless services. I've tried disabling the specific services to no change in my issue, but never really tried entirely shutting down steam or geforce experience, I'll give that a shot thanks. – joren Nov 28 '18 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.