-2

I'm creating a map in Minecraft 1.13 and I'm trying to replace a custom head on an armor stand, and then back again.

I'm using this command to summon the armor stand:

/summon armor_stand ~ ~ ~ {NoBasePlate:1b,ShowArms:1b,Rotation:[77f],ArmorItems:[{id:"diamond_boots",Count:1b},{id:"diamond_leggings",Count:1b},{id:"diamond_chestplate",Count:1b},{id:"player_head",Count:1b,tag:{SkullOwner:{Id:"401c89f6-384e-473d-b448-1c73a342aed9",Properties:{textures:[{Value:"eyJ0ZXh0dXJlcyI6eyJTS0lOIjp7InVybCI6Imh0dHA6Ly90ZXh0dXJlcy5taW5lY3JhZnQubmV0L3RleHR1cmUvOTVhZWY4ZDczYzZiM2I5N2Q3YjU3MTZmY2EyMTVmNWViYTY3OTkyMTJkMTFlYjYzZTE1ODg5NDBkMWUyMWI3MyJ9fX0="}]}}}}],HandItems:[{},{}],CustomName:"{\"text\":\"Sans \",\"color\":\"aqua\",\"bold\":\"true\"}",CustomNameVisible:1b,DisabledSlots:2039583,Pose:{Head:[348f,10f,0f],LeftLeg:[3f,10f,0f],RightLeg:[348f,18f,0f],LeftArm:[348f,308f,0f],RightArm:[348f,67f,0f]}}

and it works fine. However, when I use a replaceitem command, like so:

replaceitem entity @e[name=Sans] armor.head minecraft:player_head{display:{Name:"{\"text\":\"Sans Glowing Eye\"}"},SkullOwner:{Id:"348c464d-6df2-4921-be8a-f29a166fe9d8",Properties:{textures:[{Value:"eyJ0ZXh0dXJlcyI6eyJTS0lOIjp7InVybCI6Imh0dHA6Ly90ZXh0dXJlcy5taW5lY3JhZnQubmV0L3RleHR1cmUvZDFlNzc3ODA5M2Q5NDUxNDU2ZjU2MmEzYTU3OGViOWZkOGIyYmUxZWUzMDE0Y2UyNjllNzI1NTI5YjQ3YThlIn19fQ=="}]}}} 1

The command block responds with "no entity was found".
And in case you were wondering, this is a singleplayer world, with cheats on, and it has no functions installed.

  • If you're using redstone in your command block contraption, it's causing more lag than necessary. Redstone isn't needed for command block contraptions in 1.13. I recommend watching/reading a commands tutorial for 1.12 or 1.13. – Fabian Röling Aug 26 '18 at 18:50
0

Names can now (properly) contain spaces, so you have to quote them: @e[name="Sans"]

  • it doesn't work... :/ – 4AC11 Aug 28 '18 at 1:06
  • Oh, sorry, seems like I have confused it with something. Correcting now. I wrote that first answer without looking up anything. And I'm still pretty sure that names are now JSON and you can at least do something similar to what I originally wrote, but I also wasn't able to get it to work in a quick test, so I just replaced it with the easier format that apparently also still works. – Fabian Röling Aug 28 '18 at 6:26
  • Got an answer from an expert: "[...] in the name selector argument you just use the plain name (which is useful if you don't care about the format). If you want to test for the formatting as well use @e[nbt={CustomName:"{\"text\":\"test\"}"}]" – Fabian Röling Aug 28 '18 at 11:15
  • well, I replaced the "text" with "Sans" and nothing. Then I tried "sans" and still no dice. I also replaced "test" and "text" with sans and Sans at the same time but nothing. am i putting the name in the wrong place? – 4AC11 Aug 28 '18 at 19:39
  • 1
    well. that was quite pointless. Turns out the ENTIRE problem was with the summon command itself. I had accidentally put "Sans " instead of "Sans"... so, thank you for trying to help. If you hadn't answered this post, I probably would have deleted it by now. and then I would never have noticed! so, thanks a bunch, Fabian. and Stay Determined! – 4AC11 Aug 30 '18 at 1:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.