0

I am on a 4K monitor, but I want to play Rust in 3200x1800 or 2560x1440 for the performance. However, whenever I select a different resolution in the launcher, it will always go back to my native resolution.

Is there a way I can lock the resolution at one of these without having to set my desktop resolution as one of them?

1 Answer 1

1
+50

This has been a bug for a long, long time in Rust.

The work around that I have found which normally works for me is when launching the game, set the resolution you want BUT also set the game to windowed mode on the launcher. Start the game, and once you're loaded into a server, press alt+enter on your keyboard to change the game back into full screen. This should keep it to the resolution that you have set, just remember to press alt+enter before you want to exit out of the game otherwise it will reset again the next time you play and you will need to do this again.

Other than that, there may be some settings you can change within the ini/config file of the game and make it read only, but I will take a look into this further and add a comment if I find something.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .