6

I got an original copy of Star Control II and I am playing it under DOSBox in my Windows 7. It all works beautifully.

However, the game come with a file named "keys.exe" which does affect the keys in Super Melee, but it does not affect the keys in the game itself: it seems to be "stuck" on Enter and Space only. (ordinary shot and special shot)

Anybody have an idea? Maybe it's something with the DOSBox and the way it maps the keys? Although it's not likely, as in the Super Melee which also runs under DOSBox it works fine.

2
  • 4
    Not a fix, but you could play The Ur-Quan Masters instead: sc2.sourceforge.net It's a modernized free version of the game.
    – Joren
    Commented Oct 31, 2011 at 11:49
  • @Maardvark thanks, the last sentence means there is separate game arriving in the package that has the same battle system, and in that game changing the keys is working fine. Commented Nov 2, 2011 at 13:16

1 Answer 1

1

Can you not re-map the keys in DOSBox itself? I believe this may change your keyboard mappings for text entry as well, but there are very few (if any) places in SC2/UQM where text entry is absolutely necessary.

5
  • Interesting idea, didn't occur to me it's possible - will give it a try soon. :) Commented Feb 15, 2012 at 7:30
  • @ShadowWizard Let me know how it goes. I remember seeing at one point that it was possible, but when I tried looking it up last night I came up dry. I'm interested in doing it for another game myself.
    – Iszi
    Commented Feb 15, 2012 at 13:45
  • I tried mapping SPACE to M and it said "Mapper file saved" but it didn't affect the game keys at all, plus I couldn't find any mapper file anywhere.. ideas? :-/ Commented Feb 16, 2012 at 22:07
  • How'd you do that mapping? I haven't dinked around enough yet to figure out where that would be.
    – Iszi
    Commented Feb 16, 2012 at 22:18
  • Activated DOSBOX directly to get its command line in there pressed CTRL+F1 to reach the mapping screen. In there you can select a key then bind it to different key. Commented Feb 16, 2012 at 22:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .