4

I'm attempting to connect my PS4 controller to a laptop over the built-in bluetooth. I pair by either holding the ps button and options (which my laptop autodetects and pairs) or holding the ps button and share and then explicitly pairing using "Add Bluetooth or other device".

The pair succeeds but when I try to actually connect the controller (by pressing the ps button), the bar flashes then goes off. On the laptop it appears as "Connected" very briefly then immediately switches to "Driver error".

I have previously managed to get it to connect without the driver error but it didn't actually work (buttons had no effect). Connecting via USB works fine.

Edit: I've now managed to get it to connect without the driver error again but nothing apart from windows' bluetooth devices screen detects it.

I've tried updating drivers and multiple reinstalls with no luck.

I don't actually own a PS4 (I bought this controller especially to use with my laptop). I'd really appreciate any help as I'm rather short on USB ports.

3

You mentioned you updated the drivers, but DS4 has no official driver on Windows 10 so I assume you are using an unofficial driver like DS4Windows.

There was a change to Windows that broke DS4Windows and effectively renders the DS4 device unusable until the user manually re-enables it. To work around this issue, you'll need to re-enable the DS4 and use a patched version of DS4Windows.

The Jays2Kings version is no longer being maintained and doesn't have a fix for this issue. If you were previously using this version, it's recommended that you update to Ryochan7's fork:

https://github.com/Ryochan7/DS4Windows

More info about the device detection issue and how to fix your DS4 here:

https://github.com/Ryochan7/DS4Windows/blob/jay/README.md#device-detection-issue

  • I've been using my controller over USB without installing DS4Windows or anything else. I also managed to get it to connect over bluetooth without the driver error as I mentioned in the question before doing any manual driver installation. I have now installed ryochan7's DS4Windows and got the controller to display connected again however DS4Windows still doesn't recognise the controller as existing (nothing does except windows). The device detection issue doesn't seem to be my problem: the DS4's entry in device manager only appears when it's connected via USB and is enabled then. – Blimmo Sep 5 '18 at 10:34
1

You cannot use the PS4 controller over Bluetooth without purchasing the "PS4 DualShock USB Wireless Adaptor", or using the USB cable. If you want to save yourself some money, using a USB cable is the easiest option.

Unfortunately, either option will take up a USB port on your laptop.

Below is a screenshot from the MacOS version of PS4 Remote Play app, indicating the two ways in which the DS4 will work. The Windows version of the Remote Play app has a similar message. I understand that you may not be using the Remote Play app on your own PC, but the message is a good indicator of what is supported.

MacOS Remote Play

  • Could I see your source for this? Only it directly contradicts this article ("any Bluetooth adapter that supports Bluetooth 2 and above should work"). – Blimmo Sep 4 '18 at 9:34
  • 1
    This is incorrect, DS4 works fine over Bluetooth on OSX and Linux, and works on Windows with third-party drivers. – nondebug Sep 4 '18 at 17:36
  • While the controller connects over Bluetooth (and I've tried this on MacOS), the controller does not actually work. An example of this is using the Remote Play app on MacOS - the controller only works if it's connected via USB or using the Bluetooth Dongle. – Niraj Shah Sep 5 '18 at 10:26
  • To me that message doesn't imply that it can't be used with other bluetooth adapters. Obviously Sony would suggest their adapter in their app. I'm just confused that there seems to be some support seeing as I can get the laptop to acknowledge its existence and connect, but not enough to actually forward the button presses. – Blimmo Sep 5 '18 at 10:47
  • I've tried the bluetooth method so I'm speaking from experience. I too can get my MacBook to connect to the DS4 using the built-in Bluetooth, it just doesn't work when I press any buttons. I cannot use it as a controller with the Remote Play app, or with any other games on my system. – Niraj Shah Sep 6 '18 at 12:49
0

I have a similar problem on my MacBook. My controller connected successfully at the first time, but failed to connect the next time. The bluetooth preferences interface said that the controller is connected but showed a loading indicator (like it's connecting) and finally failed.

I succeeded to fix it by deleting the /Library/Preferences/com.apple.Bluetooth.plist file.

  • Any idea where that would be on a windows machine? – Blimmo Jan 9 at 16:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.