1

I have a MacBook Pro running macOS High Sierra 10.13.4

I've been connecting an Xbox One controller wirelessly through Bluetooth to play games on Steam and it has worked fine. But recently, the Xbox controller no longer works with Steam. I can connect the controller fine and it recognizes that a an Xbox controller is connected when I go to the settings in Big Picture Mode. But it doesn't actually let me control the menus in Big Picture Mode or control anything in-game. Not sure what has changed to cause the issue. The controller is not the issue because I have tried different other Xbox One controllers.

I did notice that these issues started to appear after I checked "Turn off on Big Picture Exit" in controller settings. I'm not sure if this is related to the problem or merely a coincidence. I've since tried it without that box checked.

I have updated Steam to the most recent build since this event, but the problems started(and continue to persist) before I updated Steam.

Xbox Configuration Support is on, Big Picture Mode is on, controller is recognized by Steam, but the problem persists.

Any reasons why I may be having this problem? Any possible fixes?

Update:

When I plug in the controller through usb it works fine.

  • "have you tried to turn it off and on again?". Try to pair the controller again and restart your computer – SysDragon Sep 4 '18 at 8:45
  • @SysDragon I have tried this many times with no avail – Scram Sep 4 '18 at 14:05
  • Sounds like a Steam Input bug to me, and based on your testing it seems to be device-specific. Can you identify the exact model of your Xbox One controller? If it's an official Xbox One controller, can you check the model number on the inside of the battery compartment? If it's third-party, can you find out what the USB vendor/product ID values are? (On OS X you can find these values in System Information.) – nondebug Sep 4 '18 at 17:31
  • I am also having the same issue as of the last Steam update. Big Picture Mode recognizes the controller but I can't control anything in the client or in games. If I plug it in via USB, it works fine. – St.G Sep 4 '18 at 18:48
  • @St.G Hmmmm...So it seems that all we can do is petition for Steam to fix that update. Do you know which update first created the problem? I think I updated Steam since the problems began so I'm not sure which build it was. – Scram Sep 8 '18 at 3:26
0

I was having this problem too, and I went to the Controller Settings in the individual app, and turned it from "Xbox Controller" to "Force Off".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.