5

I'm currently trying to complete the "Kill Marowski" quest and it's infuriating!

I have the level 3 Sandman perk. I've tried every type of weapon. As soon as he's asleep, I sneak into his room and try to V.A.T.S. his butt. Every time his health hits 0, he sits down for a few seconds (during which time the residents have turned hostile), and then stands back up with full health.

Anyone know what's going on? Is it a glitch? Am I doing it wrong?

  • Which weapon do you use to kill him? – Exa Sep 18 '18 at 12:58
  • I've tried an extended ripper, a silenced pistol, bottle cap mine by the side of his bed and grenades. – CheeseNhamToast Sep 27 '18 at 12:20
  • Also a targeting triple barrel missile launcher lol, that one was when I got really peed off. – CheeseNhamToast Sep 27 '18 at 12:24
3

Probably a Glitch

The sitting down and then regaining all his health means the game has him marked as an essential (i.e. immortal) NPC.

Letting him reset may help:

  1. Leave the area he is in (preferably to somewhere far away)
  2. Wait for ~20 days in-game time
  3. The area should have reset

Otherwise, if you're on PC there are probably console commands that could help (either make him not essential, or simply force the quest to advance), but I don't have the info for those off the top of my head.

(Note: I've not played this mission myself, I'm basing all this off of my experience with Fallout 4 and the other Bethesda RPGs)

  • Ok, I'll give that a conscious try, although I think I've left him that long a couple of times as it's one of those frustrating quests which I only occasionally try to complete. – CheeseNhamToast Sep 27 '18 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.