2

I decided to try Steam because it has a nice controller mapping feature to Big Picture Mode.

So what I did:

  1. Mapped the keys to PS4 controller for Diablo II config
  2. Enabled Steam Overlay (in both the global and game settings, this has to be enabled for the controller to work at all)

  3. Open Big Picture Mode

  4. Run Diablo II

  5. Game works perfectly using the PS4 controller until I get a HUD notification

Press Shift + Tab to access community

This happens about 30 seconds into the gameplay... my controller suddenly stops responding; I then have to use my mouse to quit the game and try again.

If somehow I could disable that notification, I think this would work perfectly.

Has anyone had a similar issue or maybe some insight?

It is so frustrating because it works, but the notification disables it.

A part of me thinks being on a Mac could be an issue, but for those of you that don't know, Blizzard released a Mac version of Diablo 2 and it essentially works the same as the .exe on Windows.

You can even pass command line arguments; I've tried to run a couple of them (through Steam) Diablo II -glide and Diablo II -w and it doesn't fix this issue.

  • Any specific reason you are tied to Steam? You can use something like Joystick Mapper and avoid Steam altogether. – MonkeyZeus Sep 27 '18 at 16:51
  • @MonkeyZeus No reason. I am not tied to Steam. It was the only software that I knew about that could do this. I'll give Joystick Mapper a try! Thank you for the suggestion. I'll try it tonight and let you know how it works out! – Kolob Canyon Sep 27 '18 at 17:00
  • Nice, definitely let me know! I was going to recommend xPadder but then I saw the macos tag but that link I sent also has other recommendations to try. I thought I was finally done with D2 but the idea of using a controller for such an amazing hack-n-slash game could get me to fire it back up, lol. I guess it's true that you can never really quite that game, you just take extended breaks :) – MonkeyZeus Sep 27 '18 at 17:08
  • Any luck with this? – MonkeyZeus Sep 28 '18 at 12:54
  • @MonkeyZeus Sorry! I didn't get a change to work on this last night. I did notice that software is in the app store – Kolob Canyon Sep 28 '18 at 15:10
1

You have two options.

First involves turning steam community off (ref: https://gaming.stackexchange.com/a/24676/1770):

Either notifications need to be turned off globally (View -> Settings -> Friends -> Uncheck all the "Display a Notification" check boxes), or the steam community needs to be disabled in-game in order to prevent me from receiving notifications in-game.

The second option is to install DS4Windows (http://ds4windows.com/) and play with button mappings to see if you can map "Shift + Tab" to the controller

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.