3

I've run into a problem recently, it's not overly harmful - only if I'm AFKing. Occasionally, it will just pause, as if I'd hit Esc. It's happened a couple of time during an AFK session, but sometimes it'll do it when I'm actually playing, like mining or building something.

It doesn't happen regularly, like every 20 minutes or so; sometimes it won't happen for hours at a time, then twice in the space of 30 minutes. As far as I can tell, this is Minecraft doing this - my PC is not switching processes, or opening other apps or anything like that.

Edit: after applying the suggestion to use the F3+P command, the game no longer pauses.

But, I haven't seen the window lose focus, and the game will still occasionally, randomly "stop". Like, if I was moving, while holding down the movement keys, my character will simply stop moving. I can move the mouse to look around still, and click (use an item, etc), but I need to let go and press the movement key again in order to start moving again. This also affects my AFK fish farm for example - at random points, when I am holding down the right mouse button to "use" my rod, that input would be dropped.

  • 5
    There might be a regularly scheduled task that opens a new window, even if just for one frame. Try pressing F3+P and see if it still happens afterwards. – Fabian Röling Oct 8 '18 at 6:13
  • 1
    @Fabian well, it worked. However the window hasn't lost focus – Ben Oct 9 '18 at 3:25
  • I assume your keyboard and mouse are USB. Are they plugged in via a hub or directly to the computer? If they are plugged into a hub, maybe try to directly wire them to the computer. If they are already wired to the computer, maybe try a different port? – Timmy Jim Aug 27 at 11:24
  • @TimmyJim they are plugged in to the laptop directly, no hub. I have also tried all the ports, with no change – Ben Aug 27 at 11:54
  • Have you checked Task Manager to see if you have any CPU spikes or anything along those lines when these happen? This would make sure that it's not just Minecraft running down your computer. – Robbie Aug 27 at 12:34
0

I take it you're playing single player. Just hit Esc and open to LAN. That will switch to multiplayer and even if it randomly pauses the world will still run.

  • Thanks for your post! as you might notice, this issue was that the games would pause randomly. However, a suggestion was given to remove the pause functionality. The issue however that the game will still randomly stop - my inputs would drop, as if the game had paused, regardless of if the game entered the pause screen or not. – Ben Feb 6 at 1:02
0

I believe this issue is with the hibernation time of your PC. If you have been AFKing for long periods of time, the PC will hibernate(I'm not very sure of the term) and Mine-craft will go to the pause menu. To fix this issue FOR PC go to Settings -> System -> Power and sleep, the length of time that your PC will hibernate at will be there and you can change it.

For Mac go to System Preferences -> Energy Saver

  • Just FYI you posted this answer twice. – MikeTheLiar Aug 27 at 11:23
  • sorry. Didn't realise, I'll delete the duplicate – Bloodbeast 234 Aug 27 at 11:28
  • This happens while I am playing. I will be moving forward, or mining, then suddenly the inputs drop. I can continue, unhindered by pressing the button(s) again, but I have no understanding as to why they drop to begin with. The game used to pause, like the game was losing focus – Ben Aug 27 at 11:54
0

I have had the reverse problem, most prominently in Skyrim, where my character would continue walking after I'd let go of the keys for up to four seconds.

I tried a few things to change this behaviour, but finally, conjecture lead me to believe it was the high temperature of the keyboard causing this behaviour: the only buttons affected were the ones close to the top-left of the keyboard, where my laptop (due to some illogical engineering decisions) gets the hottest (the fact that these buttons are groped most of the time doesn't help).

And, indeed, switching to an external keyboard solved it completely. (Of course, this is also a good first step in isolating the problem.)
I experienced improvements using a laptop cooler, as well.

I vaguely remember having that same problem as you as well, but can't for the life of me remember what game it was or how I solved it. It does remind me, however, that you also might want to check whether or not Windows' Sticky Keys is turned on.

Not the answer you're looking for? Browse other questions tagged or ask your own question.