0

First, I apologise if this is the wrong place to post this - I don't know where else to put it. If there is a more appropriate forum, I would much appreciate being told about it. I've searched the web for any other error like this, but I can't find a solution that works.

I use a Dell Visor headset on Intel UHD 620 graphics (it runs at a low framerate, but it hasn't caused any issues until now). So far, two games are giving me "d3d11.dll caused an Access Violation (0xc0000005)" at the start of their crash log:

  • Hot Dogs, Horseshoes and Hand Grenades
  • SteamVR Home

Beat Saber crashes in the same way, although I cannot find the crash logs to verify that it is the same error. This issue does not occur with other Unity games such as VRChat or Stick Fight.

As soon as the display goes from the SteamVR loading environment to the game, the HMD rapidly (once every few frames) flickers back and forth between a black screen and the first frame that was displayed by the game. The game itself inevitably crashes between 30 seconds to several minutes later. So far, I have tried these options:

  1. Reinstalling the game, the Mixed Reality Portal and SteamVR.
  2. Reinstalling my video drivers as well as running the DirectX runtime found on Microsoft's website.
  3. Fully reinstalling Windows 10.
  4. Adding a line to Beat Saber's launch options in a (presumably unsuccessful) attempt to force it to use D3D9.

Does anyone know of another solution?

UPDATE: It turns out that VRChat has the same issue, it just doesn't crash until I've played for a minute or two.

  • ... A UHD620 is able to deal with WMR? That's really surprising. – JMac Dec 13 '18 at 20:26
0

It looks to be a bug in the game engines rendering pipelines for DirectX11 on your GPU (common issue on a lot of games which are not tested on all the GPU/drivers - a reason to make sure you have the latest version) You can:

  • try deleting the as they mentioned in a post for some issues (https://twitter.com/beatsaber/status/998117273675227136?lang=en)
  • try force launch it with OpenGL in the editor
  • send the crash report to the devs and wait for a new version update (for Beat Saber - "C:\Users\\AppData\LocalLow\Hyperbolic Magnetism\Beat Saber\output_log.txt")

Hope one of this helps. Good luck!

  • Unfortunately, the first two recommendations did not help. Forcing OpenGL causes an error to pop up reading "Failed to Initialise Player" before the game can launch, and deleting settings.cfg made no difference. I did not try submitting a crash report as this issue is not exclusive to Beat Saber, but I'm glad you told me where to find the logs as it allowed me to extract this: pastebin.com/DdX422di I cut some stuff just before the end because the same line was repeated and I needed to stay within the size limits, but hopefully this provides some insight into the problem I'm having. – thacko Oct 14 '18 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.