2

After becoming Thane of Whiterun once through the Main Quest, this has to be redone when siding with the Stormcloaks in the War. The relevant quest is this one

This Quest is not available to me. Vignar is on his throne, I already purchased Breezehome from his steward. The war is over. The option to start the quest just doesn't exist. And I checked that I am not already Thane with the guards.

I tried every console command I could find, e.g. startquest, setstage, resetquest, completequest. Nothing worked. I tried raising the relationship rank with Vignar. I tried disabling/enabling Vignar. The quest is still not available. This is currently making me not want to play anymore as the goal I set myself to keep playing was becoming Thane in every Hold, which now is impossible.

Does anybody know of other things I could attempt to get this quest started?

-1

I believe the quest you linked only applies if you weren't already appointed as Thane by Balgruuf. If you have bought the house and Lydia is available as NPC, you are already a Thane. And so the quest won't pop up.

I have no idea why the wiki says that your title is revoked, that never happened to me during my numerous play-throughs, no matter which side (if any) I picked. Unless some manner of bug is at play here.

It also doesn't make sense to revoke the title, since the only way for the Stormcloaks to capture the city is if the player sides with them. Why would they revoke a title when you played a key role in capturing the city for their faction?

  • The title is revoked though. I was Thane of Falkreath before joining the Stormcloaks and got my Housecarl (which I killed). After the war, the Jarl changed and I had to acquire the title again, although I did not have to do anything but talk to the Jarl. And the same is true for Whiterun. Jarl changes, court changes. I am not a Thane as the option to tell the guards this is not there after committing a crime. – clocktown Nov 9 '18 at 16:26
  • @clocktown Then you have probably broken something by mucking around with the console... – Amarth Nov 9 '18 at 16:41
  • I used the console only after I realised I couldn't start this quest. And I saved before I used it, then reloaded that save after it didn't work. – clocktown Nov 9 '18 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.