7

Sometimes, when I go to type a chat message on Minecraft (using t to open the chat) there is already a letter t entered in the text field.

This is only occurring in Minecraft and nowhere else. I use Minecraft on Linux (Arch and Ubuntu, problem exists in both distros) with OpenJDK.

If I assign another alphanumeric or special character key to the 'open chat' action, the problem still occurs, just with whatever key I assign. For example, If I assign p, then I will get a p entered in the text field.

If I set the 'open chat' action to Enter then it does not happen (It's a nice workaround). It is somewhat similar to this bug for Windows 10, but I don't experience this issue on anything other than Linux.

How do I fix this in a more permanent manner?

3
  • Are you 100% sure that you assigned the t key to chat, not commands? I have seen a bug where the game will insert a letter if you have that bound to commands, rather than inserting a slash Aug 19, 2019 at 9:31
  • Yes I was 100% sure. I was never able to fix it, on my new laptop on arch I got no issues at all. Nov 18, 2019 at 7:07
  • This happens to me too. I am running Ubuntu 20.04 LTS and it doesn't matter what key I bind to chat. This is a bug that needs to be fixed as it sometimes it can cause you to say rude words.
    – MrParrot
    May 13, 2020 at 10:07

3 Answers 3

2

Sadly, this is a Minecraft bug that started from 1.13. You need to play 1.12.2 or lower or manually delete the t. This is a bug recorded in the official tracker from Minecraft.

Edit: Bug report: https://bugs.mojang.com/browse/MC-122477 | Fix (Fabric mod): https://github.com/RecursiveG/Mc122477Fix

2
1

I think that maybe your chat key gets stuck a bit and enters 2 "T's" into the game. If you want to, you can rebind the Open Chat key or you can just delete the T. Hopefully its because of the T key and not the game

2
  • 4
    I was thinking about the getting stuck thing too, but it's funny that it only happens in Minecraft, so no problems in LibreOffice for example. I was thinking it could be a OpenJDK issue but am not sure how to test ist as I don't use any other Java software. Nov 20, 2018 at 7:08
  • Same thing happens to me on my newly installed Ubuntu 18.04. And no it's definitely not the keyboard, as I use the very same hardware with a Win MCJE and calling the chat works perfectly with T on the other OS. So to me that is strong evidence of a glitch and its still present in MC 1.15.1
    – Cee
    Jan 11, 2020 at 6:25
1

Adjust the speed that keys get repeated

What could be happening, is that your operating system is detecting a "Key held down" event - and thus starts repeating that key before you release your finger, inserting a t (or whatever character you set your keybind to in Minecraft) into the chat box.

Given that you say this only happens 'sometimes', you're probably pressing the key just the right amount of time to start the repetition, meaning you should only need to adjust it slightly for it to not repeat on you.

Ubuntu

Change/Adjust the 'Repeat Keys' setting. From this Ubuntu help page:

  1. Open the Activities overview and start typing Settings.
  2. Click on Settings.
  3. Click Universal Access in the sidebar to open the panel.
  4. Press Repeat Keys in the Typing section.
  5. Switch the Repeat Keys switch to off.
    Alternatively, adjust the Delay slider to control how long you have to hold a key down to begin repeating it, and adjust the Speed slider to control how quickly key presses repeat.

ArchLinux

This can be achieved by adjusting the 'typematic delay' settings, using the command kbdrate. From the ArchLinux wiki:

The typematic delay indicates the amount of time (typically in milliseconds) a key needs to be pressed and held in order for the repeating process to begin. After the repeating process has been triggered, the character will be repeated with a certain frequency (usually given in Hz) specified by the typematic rate. These values can be changed using the kbdrate command. Note that these settings are configured separately for the virtual console and for Xorg.

# kbdrate [-d delay] [-r rate]

For example to set a typematic delay to 200ms and a typematic rate to 30Hz, use the following command:

# kbdrate -d 200 -r 30

Issuing the command without specifying the delay and rate will reset the typematic values to their respective defaults; a delay of 250ms and a rate of 11Hz:

# kbdrate
1
  • That did not work on Ubuntu 20.04. I have set the delay to the maximum and the speed to the slowest; it still does that, although I literally need to hold any button for like 3 seconds to start repeating. Is anyone aware of a forge mod that could just bring bad good old fashioned chat? I did not have this issue on 1.12.2 and below
    – undefined
    Jan 8, 2021 at 20:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .