1

I wanted to give my housecarl a new weapon so I dismissed my current follower (Jenasa) and quickly had my housecarl follow me. I gave her the weapon, Had her return home, and caught Jen as she was at the door. I re-hired her. She confirmed it, then walked out the door. I waited a second and she didnt come back. I stepped outside and she wasnt there.

I found her in the Drunken Huntsman and she said I already had a follower. I tried going back to my housecarl and she said the same thing. I even tried Lydia. And no I'm not doing the companions quest. I can't reload without doing some severe backtracking. (I guess I got unlucky with my auto saves) can anyone help me? I do not have any acess to console commands.

  • Have you looked here? Depending on what platform you are on and what game version you may be talking about, you might be able to try some of those answers. You may also want to look here. – Timmy Jim Nov 26 '18 at 14:35
  • Thanks. Hopefully when I do Odavings Quest it will work. – UniqueNameGoodSir Nov 26 '18 at 18:56
  • I'm on switch btw – UniqueNameGoodSir Nov 26 '18 at 18:57