2

I first documented my issues here: https://steamcommunity.com/app/346110/discussions/0/1741103267317324804/

I have five total computers in my house:

  • My desktop
  • My wife's desktop
  • My gaming laptop
  • My wife's gaming laptop
  • An extra desktop that we use for running servers sometimes

I've installed ARK: Survival Evolved Dedicated Server Tool on the extra desktop and I'm running a server there. In the Steam server list, my wife is able to see this server. None of the other 3 computers (my desktop or either gaming laptop) can see the server. My wife can even connect to the server and play.

I've also tried running a server on my desktop and on my gaming laptop. Each time my wife's desktop was able to see the server and the extra desktop was able to see the server. Those two computers can see any server that we run anywhere in the house. Meanwhile the other three computers can only see a server if they are the host. They are completely oblivious to the network.

So far for troubleshooting I have tried:

  • Ensuring ARK is allowed through the Windows Firewall
  • Disabling the Windows Firewall
  • Updating ARK (patch 288.114)
  • Updating Steam (build 1543346820)
  • Verify there are no mods installed
  • Verify there is no DLC installed
  • Validated Local Files in Steam
  • Enable Network Discovery and File Sharing and disable Password-protected Sharing in the Windows Network & Sharing Center
  • Disabled all network adapters other than Ethernet
  • Tried a different Ethernet port on the router
  • Disabled Family Mode in Steam
  • Ensured my account had no VAC bans
  • Tried logging in to my wife's Steam account
  • Disabled IPv6 on the Ethernet adapter
  • Reinstalled the Microsoft-provided network driver (last updated May 2015)
  • Updated to the latest manufacturer-provided network driver (last updated July 2018)
  • Disabled BattlEye on the server
  • Unplug Ethernet entirely and use WiFi
  • Restart the router
  • Set the MTU on my computer to maximum (1500)
  • Join the server from my wife's desktop and then invite my desktop (I received the invite but upon clicking it I received the error message "Unable to query server info for invite")
  • Set up port forwarding for ports 7777-7778,27015-27016 on the router and connect via our public IP address instead of using LAN

None of this worked. As some additional information gathering I tried installing the dedicated server software on various other computers, and checking to see if I could see the server from various other computers.

  • When the server was running on the extra desktop, I could only see it from my wife's desktop and the extra desktop
  • When the server was running on my desktop, I could see it from my desktop, my wife's desktop, and the extra desktop
  • When the server was running on my gaming laptop, I could see it from my gaming laptop, my wife's desktop, and the extra desktop
  • When the server was running on my wife's desktop, I could see it from my wife's desktop and the extra desktop

So it seems like:

  1. My wife's desktop and the extra desktop can see servers anywhere in the house
  2. The other 3 computers can only see their own local servers, but nothing on the network

Finally, I tried some other games to see if the issue was limited to ARK. I installed dedicated servers for 7 Days to Die, Half-Life and Left 4 Dead. In every case it was the exact same. My wife and the extra desktop could see the server. The other 3 computers could not.

Note that I only have issues discovering and connecting to Steam servers. All 5 computers can use the internet, all 5 computers can file share between each other, and if I enable port forwarding I can run a web server or other service and access it via my public IP. I also have no trouble joining non-Steam games like Heroes of the Storm or Hearthstone

I've spent nearly 8 hours trying to diagnose this now and I'm losing my mind. The only thing I haven't tried is reinstalling Windows.

Update (additional details)

My friend on the other side of the city tried connecting to the server via the public IP, and it worked

I connected to my phone's hot spot via WiFi and tried connecting to the serve via the public IP, and it failed

An odd pattern:

  • My wife's desktop is a Dell
  • The extra desktop is a Dell
  • My friend's computer is a Dell
  • My computer is an iBUYPOWER
  • The gaming laptops are ASUS

All 3 computers that work are Dell. All 3 computers that fail are not Dell.

Update 2 (more details)

When I go to the "Internet" tab in the server list, instead of the "Favorites" or "LAN" tabs, I can scroll down and find the server (after all, I did set up port forwarding so it could be found via public IP)

I verified and this method works on all five computers in our house. Meaning even though I can't see it via LAN or in Favorites, I can still see it via Internet

When I right-click the server under the "Internet" tab and select "Add server to favorites" and then go to the Favorites tab, it briefly shows the server information for a few seconds while the list refreshes, and it's then promptly replaced with "< not responding >"

However if I connect directly through the "Internet" tab, then the server loads and I can play the game just fine (albeit going out to the internet and back in via public IP, so I ping around 30-40 milliseconds instead of 1-10 milliseconds I would expect on a LAN game)

So my computer (in fact, all 3 computers that are failing) are able to access the server and transmit game data no problem. It's only server discovery that's failing.

  • Is your network set up with multiple access points, extenders, etc? Are the affected computers connected to the network differently than the ones that work (wifi vs ethernet)? – Paul Jan 3 at 20:59
  • @Paul We only have one router, and no range extenders. The router does have a 2.4Ghz and 5Ghz band. One of the working computers (the extra desktop) is on the 5Ghz band, the other working computer (wife's desktop) is on Ethernet. One of the failing computers (my desktop) is also on Ethernet, and the other two failing computers (gaming laptops) are on the 5Ghz band. The 2.4 Ghz band is used exclusively by cellphones, our Roomba, the Nintendo Switch, etc. – stevendesu Jan 3 at 22:57
  • Maybe you'll find something you haven't tried in this guide arksurvivalevolvedforum.com/viewtopic.php?f=12&t=8 – Paul Jan 4 at 18:55
  • @Paul So I read through the whole thread and most people either had trouble getting the server to start, or could connect on LAN but not over the internet. One person (on page 6) had the same problem I did, but no one noticed their post or helped them. – stevendesu Jan 5 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.