1

I've recently upgraded to the X52. Got it from a friend who it was working perfectly for, he just wanted the pro model.

After installing drivers and setting up, I found it significantly more difficult to control than my previous Thrustmaster T-Flight. After some investigation, it appears a slight touch on my joystick for pitch or roll is resulting in the same as me pulling the joystick to full length; It's either at 0% or 100% at any time.

The driver/Windows software shows that the variance is definitely there and shows partial movements. I've tried out "Joytester 2" - which appears quite popular - and this shows my X and Y as being 65535, 32767 or 0. 65535 is the top of an unsigned 16 bit number, and 32767 is the halfway point between it and 0, so it appears to me that there are 3 possible states this application can see my joystick in.

Contrarily I tried my rudder and throttle (z rotation on joystick and z axis on thruster) and (as you can see from the below screenshot) I could get fairly concise movements. In the same screenshot you'll see the X and Y (top left) instantly crossing the drawing area. You'll also see the sensitivity is definitely received by Windows, as the Saitek driver/software shows the correct partial sensitivity as I move the X and Y roughly halfway. This indicates to me that there cannot be a hardware issue, and the issue is either in an ED component that the Joytester 2 software shares, or it's some form of driver issue/software incompatibility I need to resolve.

Edit: I should mention that the bindings are the default Saitek X52 present in game.

1 Answer 1

2

The issue is solved!

It appears this regedit for re-calibration of off-center axis resolves the issue:

https://support.logitech.com/en_us/article/Recalibrate-controller-axes-RegEdit

For future readers if this link no longer works, here is the entire contents of the .reg file:

Windows Registry Editor Version 5.00 

[-HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\DirectInput\VID_06A3&PID_075C]

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\VID_06A3&PID_075C]

It appears to be clearing the value of "VID_06A3&PID_075C" (the hardware ID of the X52) from the registry. I did uninstall the drivers, but I guess this value stuck around. At some point during driver installer, it must have set invalid values here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .