4

I use Nvidia's DRM (Direct Rendering Manager) Kernel Mode Setting (see https://wiki.archlinux.org/index.php/NVIDIA#DRM_kernel_mode_setting) to get rid of screen tearing on my desktop. I've also tried to use compton to get rid of screen tearing but their solution doesn't seem to do anything.

Sadly this also locks my fps to 60 in Payday 2 and it causes tons of mouse input lag, making aiming very difficult. The vsync or max fps settings don't do anything.

I don't have this problem with any other game.

These are my laptop specs:

  • i7 7700HQ with Intel HD Graphics 630 (but using dedicated GPU of course. Both are enabled in BIOS settings)

  • GTX 1050 2GB VRAM (with latest proprietary drivers)

  • 8GB RAM

Disabling DRM KMS fixes the issue, but I want to keep it enabled to fix screen tearing on my desktop.


Things I've tried so far:

None of these work for me.

  • 1
    I initially thought this was referring to a different kind of DRM you often encounter with games. – JAB Feb 7 at 0:43
  • I edited the post and title :) – zjeffer Feb 7 at 10:06

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.