0

To summon a baby villager, I run

/summon villager ~1 ~ ~1 {Age:-6000}

It seems like I am getting brown coated villagers every time.

Fletcher, farmers, fishermen and shepherds.

Is that command line wrong or is there a bug?

edit

It seems like I get all types if I summon adult villagers.

  • Which version do you play in? – Fabian Röling Feb 10 at 10:52
  • Ok, snapshot apparently, found the cause. – Fabian Röling Feb 10 at 10:55
2

This is the bug MC-140961: "Villager babies have no profession"

When you spawn baby villagers, the command feedback actually tells you "Summoned new Nitwit", "Summoned new Cartographer" and so on, but they all turn out to have brown coats. When they grow up, they get their proper coats, but if they randomly happen to keep a brown coat, you cannot trade with them.

This apparently means that there can be no new farmers, fishermen, shepherds or fletchers (that can trade) apart from the ones generating with villages. This is a pretty big problem for Skyblock-type maps, since it makes optaining some items considerably harder, for example cookies would now require a wandering trader.

Since this is a pretty bad bug, I invite everyone reading this to vote for it on the bugtracker, so that it gets more attention from the developers and hopefully gets fixed before 1.14.0.

  • But I get command feedbacks like "Summoned new shepherd". They are not professionless, but their professions are only a subset of all professions. Those with brown coats. – Anders Lindén Feb 10 at 16:18
  • As I said, they have different professions, they just all look the same as babies. And when they become adults, they show their professions, but brown-coats don't trade. – Fabian Röling Feb 10 at 16:32
  • If I use the summon command with age -6000, I will never get a feedback message like "Summoned new Librarian" but for instance "Summoned new Shepherd". They do not seem to have their coats or professions changed when they grow up. – Anders Lindén Feb 10 at 16:42
  • That's weird, it's different from how it behaves for you. Which version are you in? – Fabian Röling Feb 10 at 16:51
  • 1.13.2. It seems like Profession defaults to 0 if I have specified Age (but Career is random). If I run the command without Age both are chosen randomly. – Anders Lindén Feb 10 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.