1

I'm making a custom boss set for my Minecraft server and as such I've decided to include some epic battle music. I've managed to get the music into the resource pack, and the sounds work and play in game, however between five to twenty seconds into the song it suddenly cuts off and stops playing. As far as I can tell there's no actual reason for it doing this as it seems to do it at random intervals in the song. I've tried turning down the volume parameter or changing the position the sound spawns at but to no avail. Nothing shows up in the console when the sound is stopped.

The command I'm using is as such:

/playsound minecraft:music.hellofatime master @a[distance=..200] 696916 27 -697075 9999 1

It works fine, but after a while it simply cuts off. I've seen other posts with a similar question be told to change all of the vanilla music files to an empty file (I just used half a second of silence as the files) and I've done that, but it'd didn't seem to help.

What's interesting is that this doesn't happen on my singleplayer worlds. Could this possibly have anything to do with me not having the resource pack on the server (I'm going to update it into the server config later) but instead using a client-side one?

I'm really not sure what to do, any help would be appreciated. Thanks!

  • You could try putting it into a server resource pack and see whether that fixes it. Maybe it has something to do with the server not knowing how long the music is, but even then it's weird that it stops randomly instead of predictably. It definitely sounds like a bug. Also, could you upload the resource pack? Or, if there's issues with copyright, try to find another that reproduces the issue, then upload that? And lastly: Is there server lag or anything like that? Or anything else that's special? – Fabian Röling Feb 12 at 11:06
  • Also, which Minecraft version? – Fabian Röling Feb 12 at 11:17
  • Version 1.13.2. I've uploaded the resource pack here: minepack.net/download/48fceda651b2f940576cda827ff9ed17 But now that I've done that and input the resource_pack and sha_resource_pack options in the server config the resource pack doesnt even load. There might be something wrong with my sound.json? – goldrat1 Feb 12 at 12:19
  • Try with an example resource pack for 1.13 that you find online. If that works, keep changing and testing it until you have your resource pack again. If it fails at some point, you know what causes it. If it doesn't fail, congratulations, you're done. If it fails right from the beginning, try other resource packs. If even that doesn't work, report it on the bugtracker (and here). – Fabian Röling Feb 12 at 14:29
  • I just tried the resource pack and the sound doesn't even start playing for me. I've also tried some variations of that command, none works. Are you sure the resource pack and command are correct? – Fabian Röling Feb 12 at 21:45
0

You mentioned that this only happens in certain areas of the world. So this might be the bug MC-1538: When too many sounds are supposed to play at once, then seemingly randomly some of them are cut off. It got a lot better in 1.11, but still happens.

To solve this, try removing sound sources within hearing range. Especially animals, liquids and active blocks (like furnaces, brewing stands, …) cause a lot of sounds. Many mobs colliding with each other cause an extreme amount of sounds, since they all constantly move.

  • Shit. The area's a Nether Level. Lots of lava. Hmmm. – goldrat1 Feb 14 at 21:23
  • Can confirm, looks like its MC-1538. . Turning off Block sounds seemed to do the trick. Shame, really ruins the immersion a bit. I prefer the music though. Thanks for your help! – goldrat1 Feb 14 at 21:32
  • You could record some of the bubbling sounds and edit your piece of music to include it. Then, when it ends, play another track that only includes the bubbling. Kind of crazy, but if you want maximum immersion, might be worth it. – Fabian Röling Feb 15 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.