2

I play DF on PC for years, and had never encountered this before.

I installed DF on my Mac, and I am experiencing really annoying lag with keyboard input. When I press a key there is ~100-200ms delay before I see action happening on the screen, this makes it really hard to play the game (tried LNB and completely vanilla, no difference).

This is unrelated to FPS or CPU performance, because I see the same behavior even in the main menu

Have anybody experienced that? Is there any way to solve that?

Thanks!

1
  • Did you set the delay of your keyboard in your Mac settings ? Check if when you run the game, this setting isn't reset
    – Chocobouc
    Feb 13 '19 at 9:39
1

This will sound silly, but try scaling the window down to a smaller size.

Experience: I have the same problem. I downgraded Dwarf Fortress and thought it fixed the problem. Once I scaled the views to be the same size, the lag reappeared.

Reference: http://www.bay12games.com/dwarves/mantisbt/view.php?id=11034

1
  • Very helpful! In case that link ever stops working, the fix for me was to open ./data/init/init.txt and change the PRINT_MODE to FRAME_BUFFER. After doing that, I could maximize the window without any problems. Jun 16 '20 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.