3

I just learned the Dragonrend shout and am fighting Alduin, but this has been going on for like an hour now (no joke), and Alduin's health has not changed. I have pretty decent gear and am level 18, but this fight is going nowhere: I've died like 4 times, and I quicksaved a bunch to keep me from starting over, but this is insane! My weapon may be nothing compared to Alduin's HUGE health, but any suggestions would be greatly appreciated.

2 Answers 2

2

There was aparently a bug in early-versions of the game, potentially still existing here today, where he is not able to take damage.

Some had luck in restoring his ability to be damaged by exiting and reloading the most recent save.

Since you're playing the Xbox version, the best bet would seem to be to reload the most recent save. There doesn't seem to be any definitive fixes among the results I've found.

3
  • I just wanted to point out that I am playing on the remastered version of Xbox skyrim so I honestly don't know what to do Feb 22, 2019 at 2:50
  • Just saw the answer selected as answered, did you find a route that worked for you?
    – Kyle
    Feb 22, 2019 at 3:06
  • 2
    Confirmed here.
    – Joachim
    Feb 22, 2019 at 13:20
0

Try this: before Alduin shows his presence fast travel anywhere and fast travel back. His health should start going down. I had this bug before and this worked. The difference is I'm on PS3, It'd still be a good idea to try this though.

1
  • 1
    Do you have any information to support that this works, or is this just from something that you tried doing by yourself? Jun 19, 2019 at 6:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .