4

I've checked all the other answers and I can't seem to find one that fits my situation. I'll go ahead and list everything I've tried, that way we can cruise through the generic answers.

Heads Up: New PC. Downloaded Java 64x. Copy and Pasted old PC's .minecraft folder. Same specs except for CPU and GPU. It is Modded.

Problem: Everytime I launch Minecraft without allocating any RAM it starts fine but with only 500MB of RAM allocated. I can't add arguments or I get a "Java Virtual Machine" Error. Changing the Environment Variables doesn't affect the 500MB of allocated RAM. If I just add the -Xmx1G etc... argument it launches with 500MB of RAM regardless, unless I add more than 4GB then it spits out the "Java Virtual Machine" error.

Things I've Tried

  • Installed Java 64x
  • Reinstalled Java 64x
  • Re-reinstalled Java 64x
  • Ensured I was using 64x Java and not 32x
  • Made changes to Environment Variables
  • Turned it off and back on again
  • Set specific arguments
  • Reinstalled Minecraft.
  • Re-reinstalled Minecraft.
  • Forced Minecraft to Update (with an error)
  • Googled fixes for several hours
  • Found nothing
  • Posted here and several other places.
  • Awaiting replies...

*Also, don't know if this is important, but the Java website can't verify my Java.

  • Could you give some specifics about the Java version you're trying to use, as well as the Minecraft version, your Windows version and the command you're trying to use to start Minecraft? – Nzall Feb 27 '19 at 15:55
  • 2
    Also be good to know how much available RAM you have... – Stese Feb 27 '19 at 16:06
  • also, how much minecraft starts with isn't important, it requests RAM up to the limit its been allocated. If you want it to start with more, use Xms<ram>. – Stese Feb 27 '19 at 16:15
  • 1
    Do you mean "64 bit"? Because I doubt you really installed Java 64 times. Also, what's the error you get? – Fabian Röling Feb 27 '19 at 18:27
  • 1
    I honestly don't know what was causing it but it managed to fix itself after the third attempt at restarting and relaunching minecraft. – Mr. Wulf Feb 27 '19 at 21:17
0

To those having similar issues in the future:

Typing cat /proc/meminfo into the command line will inform you how much RAM you have free on your computer. Oftentimes there's just a lack of memory, meaning you need to either close some programs or upgrade your RAM.

If you definitely have enough memory (at least 1GB more than you want to dedicate), then adding -d64 to the same place where you put -Xmx and -Xms will force Minecraft to use Java x64 rather than any Java x86 that somehow snuck onto your machine.

Furthermore, you can try adding the 64-bit java to your computer's PATH:

  1. Right click on My Computer/Computer (on win10 simply enter settings and search "system settings" then skip to step 4)
  2. Go to Properties
  3. Go to Advanced system settings (or just Advanced)
  4. Click Environment variables in the bottom right.
  5. Add the location of the folder that javaw.exe is in to the PATH by clicking Path then clicking "Edit", then clicking "New" and adding it there - ensure there is a semicolon (;) at the end, or it won't work. (Note: If the PATH variable doesn't exist among "User variables" click "New", and set the following: Variable name = PATH, Variable value = location of the folder javaw.exe is in (this is often Program Files).)

If the issue persists beyond that, you don't have 64-bit Java installed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.