0

My friend and I recently downloaded COD:MW2 and were able to connect when on his LAN and play several games. It was great. But then we weren't able to connect anymore, even when still on his LAN. I don't remember what changed--whether one of us restarted or just disconnected from the game but we could no longer send each other an invite. Since then, we've tried to connect via internet (we live in different states) to no avail.

I can connect to online games using Find Game but cannot join a private match or invite friends. Clicking Invite a Friend does absolutely nothing--no message, nothing.

My Nat Type is stubbornly stuck on Strict, no matter what I do. I have tried port-forwarding all the relevant ports, putting my PC in the DMZ, toggling UPnP off and on, etc. Nothing seems to work.

I've run a third-party utility that has verified that all the necessary ports are open but still no joy. Can someone help me troubleshoot this? I hate the idea of just deleting this fun game because a core feature doesn't work like it's supposed to. I've read every article I can find and watched every video that claims to fix the NAT Type issue but nothing has worked.

I have a Dell XPS 15 running Windows 10. My router is a Linksys E2000. Thanks.

New contributor
johnnyb1970 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

johnnyb1970 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.