I am trying to play a map on LAN. But every time I try to log on, I get:

java.net.ConnectException: Connection refused: no further information:

This used to work, but for some reason has stopped all of a sudden. I looked it up online, and everything I found said the firewall just wasn't allowing Java through. I followed tutorials to allow Java through the firewall, but even then it won't work. I know for a fact that I'm putting the IP in correctly, and everything seems to be correct, but yet I still get the same error message.

If it helps any, I'm using MC version 1.8.9 (the map requires it), and I don't have any mods.

  • To get a more complete answer, you need to give us more information on the setup of both machines. IP address configurations, any intermediate hardware that might have changed, etc etc.
    – Stese
    Commented Mar 20, 2019 at 14:03
  • I suggest you report that to mojang
    – Asadefa
    Commented Mar 20, 2019 at 23:39
  • @Asadefa :- I don't think the OP will get any help from Mojang in this case, as i very much doubt it's a minecraft bug...
    – Stese
    Commented Apr 23, 2019 at 6:35

1 Answer 1


"Connection refused" Is the key here...

It's basically reporting that while the game was able to make contact with the physical device, the device did not accept the connection.

This is likely due to either a change in configuration on the Minecraft server software (a change in port for instance), or a change to the firewall settings on the physical machine.

With the information you have provided, this is the only answer we can give you.

Not the answer you're looking for? Browse other questions tagged .