1

I bought a PS4 that I have never had any problems with until now.

I was just playing God of War. I used the PS button to go back to the Home menu and wanted to change some settings. As a result, I suddenly found that all the buttons except the PS button failed on the Home menu.

I pressed the power button to put it in standby mode and restart. After restarting all the keys were normal in the home menu, but any game using the gamepad did not work, as only the PS key has a reaction.

Is there a way to fix this?

0
3

This is a tricky one, mainly because from what you describe it seems like one of the buttons on your controller is stuck and it's overriding the rest.

But before addressing that, you can try a few things first:

  • Completely turn off your console (not rest mode), wait a few minutes and turn it back on.
  • Reset the controller by sticking an unfolded paper clip in the small hole on the back of the controller. You can check Step 3 on DS4 troubleshooting guide
  • Launch a game, when in-game, turn off the controller (hold middle button > Adjust devices > turn off controller) and then turn it back on.

If the above don't work, there's a good chance that a button is stuck on the controller and is blocking the rest of the buttons to work properly.

You can check this by connecting the DS4 controller to a computer the USB cable, the drivers should be installed easily on their own and then check the controller's properties. Windows have a screen which shows which buttons are pressed. If you have a button stuck it should show up as pressed all the time.

If you can confirm that the button is stuck, then you need to clean it.

On a Reddit thread I was reading, someone said that they smacked the controller against their thigh a couple of times and the controller worked fine afterwards. For the record, I don't take any responsibility if you break your controller.

There are several ways to clean it, like compressed air or taking it apart completely. You can check this Reddit post about dealing with a stuck button.

2
  • 1
    I personally experienced this rather recently myself, and all the above help. The only thing though is that resetting the controller was only temporary (turning off/on the controller had the same results). For me, I ended up taking the controller apart and discovered one of the internal components was loose. After putting it back in-place, the controller functioned properly Apr 3 '19 at 11:46
  • @Wondercricket I'm afraid that's probably inevitable. It sounds like a hardware failure.
    – Xander
    Apr 3 '19 at 11:49
0

Sounds like It's a sticky button issue, happens often on my controller cause I have stickers on it. Like shake it and slide your palm over the input buttons to loosen them up, not too rough though but a little firm to dislodge any crud that might be causing the button to be stuck. Do I while in an app and you should see something move eventually on the screen and then you'll know it's working again 👍

0

Best way to deal with this is:

  1. Open any game in which the controller is not working
  2. Press the PS button whilst being on the game screen
  3. Go to device setting tile
  4. Turn off the controller
  5. Turn the controller back on
  6. Do all the above steps after opening the game and not on the home screen.

This should solve it, certainly did for me.

0

I just bought a new PS4 controller and had the same issue. I don’t have the knowledge or tools to clean it so I was just going to bring it back. I figured I’d try “smacking it on my thigh” and sure enough it worked!

Lol I’m so happy!