It seems that despite no matter how many combinations of right clicking, left clicking, and favorites I set up, I can't seem to use a shield in one hand and magic in the other.

Is this always impossible? Is there perhaps a perk that allows this ability?

  • I'm getting this too! I can only set things into my left hand. I somehow got one spell in my right hand, but now I can't set anything else there! I tried changing key bindings etc. – user13971 Nov 11 '11 at 9:07
  • I have the same issue :( Left mouse assigns fine but since i set the right spell it wont change ! – user13972 Nov 11 '11 at 9:14
  • It appears to be that you can't unequip a one-handed weapon from the favorites menu in favor of a spell - it will always put it in your left hand. I've seen people reporting success by equipping a 1-handed weapon in each hand, unequipping them, then trying to equip the same spell in each hand. – Ian Pugsley Nov 11 '11 at 18:00
  • Just equip the weapon/shield in the left hand first and then equip the spell in the right hand. Works every time. – user9983 Nov 12 '11 at 17:03
  • Except when it doesn't (especially from the favorites menu). – Ian Pugsley Nov 12 '11 at 17:54

This is possible from the beginning, I'm running around electrocuting enemies with my right hand and blocking with a shield on my left hand pretty much since the beginning of the game.

Left clicking assigns the item or spell to your right hand and right clicking assigns it to your left hand. So you want to right click on a shield and left click on a spell.

To activate the spell or block with your shield the mouse buttons are reversed from assigning, you activate your right hand with a left lick and your left hand with a right click.

Favoriting just puts the item or spell into a list you can access via the Q key, you can equip from the inventory directly or from your favorites list.

enter image description here

It should look like this, where both the shield and the spell are marked in the inventory and favorite list:


  • Hmm, fairly sure I tried that specifically - had trouble getting spells into my right hand at all. I'll double-check. – Ian Pugsley Nov 11 '11 at 6:06
  • 1
    @Ian From the other reactions here it looks like there might be a bug related to this. The way I wrote it worked for me without any issues. – Mad Scientist Nov 11 '11 at 9:24
  • 1
    left click for right hand, right click for left hand...that's so counter-intuitive! I can understand normal left clicking for the usually default right hand in many circumstances, but when dual wielding is a big part of the game it seems needlessly confusing – Alex Nov 11 '11 at 9:25
  • 1
    @Alex that's just the default controls. First thing I did was flip them. – wersimmon Nov 11 '11 at 9:29
  • @echoback just as well it'll let you, some games are a bit dumb like that :) – Alex Nov 11 '11 at 13:08

No, it's a bug, and Ian is right.

Read this on Amazon.com (http://l0.ro/28K) That guy experienced the same thing as myself.

It is nearly impossible to use spells, only one spell may be selected at a time, and there are no hotkeys for switching spells. The closest thing there is are "favorites", but these only work for one hand, not both hands.

Most spells register only on the [L] mouse button or [LR] regardless of what you've clicked and key-settings. And sometimes you can't even de-select a spell. I have not seen that with weapons but very ANNOYING.

The EVIL part is that once you connect a XBox360 controller for PC, spells have no problems selecting either [L] or [R] or whatever combination with the trigger buttons.

  • 1
    Have you tried select using E in favorites menu? – wizztjh Nov 24 '11 at 22:12
  • When it really stuck, select a bow then right click the item you want, then E the next item you want to select – wizztjh Nov 24 '11 at 22:14
  • +1 to wizztjh. I read that E will equip right hand, right-click will equip left hand. In the favorites menu, left click does nothing! I read you might have to equip a weapon, unequip the weapon, and the pick a new spell, if you want to change spells on your right hand via favorites menu. – James Nov 28 '11 at 7:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.