4

I have a couple of resource packs enabled for Minecraft. 2 of them are my own custom creations. The last one is "Programmer Art" that came with 1.14. For some reason, one of my resource packs always gets disabled upon startup, and I have to reenable it once the game loads. The other 2 remain enabled for some reason. This problem has been going on for a while, and I thought it would be fixed in 1.14, but it hasn't.

I decided to check the startup logs, and I found this warning message:

Removed resource pack file/my resource pack.zip from options because it doesn't seem to exist anymore

I figured this was the problem, but it doesn't get removed at all, it just gets disabled. My resource pack is always an option when I check, so why am I getting this message? Even stranger, this just happens to the one and none of the others. Does anyone know what's going on?


Edit:

I was given the request of providing a copy of the file, so it's available here

  • Can you upload the pack? Then we can try it ourselves. – Fabian Röling Apr 27 at 17:42
  • @FabianRöling sure, I just edited the question and gave a link. – Diriector_Doc Apr 27 at 18:01
  • It might be the name, why does it contain paragraph characters ($)? – Fabian Röling Apr 27 at 18:13
  • It stays enabled for me. Which version are you in? – Fabian Röling Apr 27 at 18:18
  • @FabianRöling the paragraph characters are for style. It makes the pack on the options screen colourful. I am using 1.14, this problem existed for me in 1.13 as well. If this problem doesn't affect you, I don't know what's going on, because it is evidently not the pack's fault. But why doesn't it disable the other 2 then? – Diriector_Doc Apr 27 at 18:56
3

With some help from Fabian Röling, we have established that the reason the resource pack was disabling itself was because of the file name.

My resource pack file contained section characters (§) in its name. This problem occurred on my windows computer but not Röling's Linux. By simply removing the section characters, the problem disappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.