2

I'd like to give a player a written book, but I keep getting "invalid book tag" whenever I actually open the book. The wiki says to use a "serialized JSON object or an array of strings and/or objects (see Commands#Raw JSON text) or an unescaped string". I looked at the link but couldn't make much sense of it, so if anyone could give an explanation of what that means that would be extremely helpful. Things I've tried:

/give @p minecraft:written_book{title:"Magick Moste Evile1",author:"Herobrine",generation:0,Pages:["{\"text\":\"Testing\"}"]} 1
/give @p minecraft:written_book{title:"Magick Moste Evile2",author:"Herobrine",generation:0,Pages:[{"testing"}]} 1
/give @p minecraft:written_book{title:"Magick Moste Evile3",author:"Herobrine",generation:0,Pages:["testing"]} 1
/give @p minecraft:written_book{title:"Magick Moste Evile4",author:"Herobrine",generation:0,Pages:[{"{\"text\":\"Testing\"}"}]} 1

Some of them don't actually run without errors in the command chat, while others give me a book but the inside just has the "invalid book tag" error message. I've looked at other questions on this site and others, like this one, but they're all for old versions and don't work when I try to update them to 1.14. What is the correct format for the pages of a written book?

2

I fixed it: the first one was correct except the pages nbt needs to be lowercase and needs to be the first nbt tag listed:

give @p written_book{pages:["[\"\",{\"text\":\"The art of rituals is of vital importance to the player.\"}]","{\"text\":\" It is a matter of life and death,\\na road either to safety or to ruin.\"}]","{\"text\":\"Hence it is a subject of inquiry which can on no account be neglected.\"}"title:"Magick Moste Evile",author:Herobrine,display:{Lore:["Of the Horcrux, wickedest of magical inventions, we shall not speak nor give direction —"]}}
| improve this answer | |
  • to make this a little more expressive, Id suggest adding the correct version to your answer to help those who are more visual learners. – Dragonrage May 10 '19 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.